directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From s_humbi <s_hu...@yahoo.com.INVALID>
Subject Master-Slave Replicaton with attribute-selection
Date Tue, 15 Mar 2016 09:01:51 GMT
Hello,

we are trying to replicate user-entries from master-ds to slave-ds.

But we want to replicate the users with some selected attributes only (objectClass, cn, ou,
sn):

ads-replattributes: objectClass
ads-replattributes: cn
ads-replattributes: ou
ads-replattributes: sn

Initial replicaton works fine. All user-entries with the selected attributes are replicated.

But now if you change only one attribute for one user on the master-ds, the complete user-entry
with all attributes are replicated (cn, ou, sn, o, l, fax, mobile, userPassword, objectClass
...).

We are using M21 and Java8. 
We tried it on Win10 and W2008R2.
We tried with "Refresh only" and "Refresh and persist".

What we did:

1 ) On the master-side we only changed the attribte ads-replEnabled to TRUE.

2)  On the slave-side, this is our simple customer-entry for testing:

dn: ads-replconsumerid=consumer1,ou=replConsumers,ads-serverid=ldapServer,ou
 =servers,ads-directoryServiceId=default,ou=config
objectclass: ads-base
objectclass: ads-replConsumer
objectclass: top
ads-replaliasderefmode: never
ads-replattributes: cn
ads-replattributes: objectClass
ads-replattributes: ou
ads-replattributes: sn
ads-replconsumerid: consumer1
ads-replprovhostname: localhost
ads-replprovport: 389
ads-replrefreshinterval: 60000
ads-replrefreshnpersist: TRUE
ads-replsearchfilter: (objectClass=*)
ads-replsearchscope: sub
ads-replsearchsizelimit: 0
ads-replsearchtimeout: 0
ads-repluserdn: uid=admin,ou=system
ads-repluserpassword:: c2VjcmV0
ads-searchbasedn: dc=example,dc=com
ads-enabled: TRUE
ads-replstrictcertvalidation: FALSE
ads-replusetls: FALSE
description: local


I am not quite sure, if this is a bug or if we did something wrong.
Can anybody reproduce this problem?

Thanks,
Humbi
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message