directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Schaefer <schaef...@mac.com>
Subject Re: Failed to Import LDIF files about updated Schemas to Apache DS through Studio
Date Sun, 09 Aug 2015 00:19:49 GMT
Of course this entry already exists because I wanted to update an object class. How would I
delete an object from a schema?

- Andy Schaefer

> On Aug 8, 2015, at 3:36 PM, Emmanuel Lécharny <elecharny@gmail.com> wrote:
> 
> Le 09/08/15 00:09, Andreas Schaefer Sr. a écrit :
>> Hi
>> 
>> First I want to thanks Apache Directory team for this great app.
>> 
>> I wanted to use the Apache Directory Studio to create a Test LDAP server for testing
user authentication. For that I need to update the existing schema in Apache DS.
>> 
>> When I tried to do that I ran into issues where I could not update an existing entry
but could create new ones. This is what I did:
>> 
>> 1) Create a new schema
>> 2) Create a new Attirbute Type and Object Class adding the new Attribute Type as
optional attribute and make the Object Class (person2) by a sub type of Person from Core
>> 3) Export as LDIF
>> 4) Import to the embedded ApacheDS server as LDIF file (update existing entries checked)
>> 5) Worked even though got some errors
>> 6) Created new Attribute Types and added them to the person2 as optional attributes
>> 7) Exported as LDIF and then imported to the Apache DS server as LDIF
>> 8) Created the new Attribute Types but failed to modify the Object Type person2 (see
the Error from the log at the end)
>> 
>> Questions:
>> - Is that the right approach?
>> - I found this ticket: https://issues.apache.org/jira/browse/DIRSTUDIO-808. Is that
a regression in M9? I downloaded and tried the same thing with M4 and it failed as well.
> 
> You had this error : Oid 1.0.0.111.1.1 for new schema entity is not unique
> 
> Which means you already have an element with this OID. Each schema
> element must have its own OID. Blind guess : your first import alreadyd
> efines this OID. Either you delete it, or you change the OID.
> 

Mime
View raw message