directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hurni, Kevin (ITS)" <Kevin.Hu...@its.ny.gov>
Subject RE: Apache Directory Studio-incorrect counts via LDAP
Date Tue, 24 Feb 2015 21:46:38 GMT
Hello, no I do not.
In this case, it's a flat AD Domain with the default:
Cn=users

I limited the query to the container in question.
The container in question is flat, no sub ou's or cn's.

It seems to be something with either the query (again, this is the only time I've noticed
it, but then again, never had a reason to doubt the number counts until this time), or something
with Directory Studio.

The query was (IMO) fairly simple:
(&(objectClass=user)(!(mail=*hr.abc.com))(userPrincipalName=*somethingelse.com))

-----Original Message-----
From: Emmanuel Lécharny [mailto:elecharny@gmail.com] 
Sent: Tuesday, February 24, 2015 4:39 PM
To: users@directory.apache.org
Subject: Re: Apache Directory Studio-incorrect counts via LDAP

Le 24/02/15 22:12, Hurni, Kevin (ITS) a écrit :
> I apologize if I'm doing this wrong, but here goes:
> Apache Directory Studio Version: 2.0.0.v20130628
>
> I'm using LDAP against a MS Windows 2008 R2 server.
>
> I constructed a search query.  It runs the query and then next to it, has a number of
items such as:
> (3686)
>
> However, if you either expand the query (click the little arrow), it shows those little
folders in bunches of 100, BUT it stops at:
> 3601...3683
>
> AND
> If I export to a .CSV there are actually only 3683
>
> So somehow, Directory Studio isn't displaying the correct count in the parenthesis.
>
> This is the first time I've ever run across this.
>
> Please let me know how to proceed.
> (Do I report a bug?)

Do you have sub-trees ?

Mime
View raw message