directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Seelmann <m...@stefan-seelmann.de>
Subject Re: Problem installing Eclipse Plugin
Date Tue, 09 Sep 2014 05:46:58 GMT
On 09/08/2014 05:42 PM, Remijan, Michael wrote:
> Greetings,
> 
> I am attempting to install Apache Directory Studio 2.0.0-M7 Eclipse plugin and I'm having
all sorts of problems.
> 
> If I attempt to install from the Eclipse Marketplace, I get this error:
> 
> [cid:image003.jpg@01CFCB51.87599BE0]
> 
> If I proceed with the installation, it messes eclipse up and I need to uninstall the
plugin to get Eclipse working again.

Unfortunately your images were filtered by the mailing list software.
Please try to upload them to some image hosting site.

> Now if I attempt to use the Eclipse "Install New Software..."  I enter the following
update site URL:
> 
> http://directory.apache.org/studio/update/2.x/
> 
> Then when I do it this way, I get the following error:
> 
> 
> Cannot complete the install because one or more required items could not be found.
> 
> Software currently installed: Apache Directory Studio RCP 2.0.0.v20130628 (org.apache.directory.studio.rcp.feature.feature.group
2.0.0.v20130628)
> 
> Missing requirement: Apache Directory Studio RCP 2.0.0.v20130628 (org.apache.directory.studio.rcp
2.0.0.v20130628) requires 'bundle org.eclipse.update.core 0.0.0' but it could not be found
> 
> Cannot satisfy dependency:
> 
> From: Apache Directory Studio RCP 2.0.0.v20130628 (org.apache.directory.studio.rcp.feature.feature.group
2.0.0.v20130628)
> 
> To: org.apache.directory.studio.rcp [2.0.0.v20130628]

You don't need the "RCP Application" feature when you install Studio
within an existing Eclipse installation. Please uncheck the "RCP"
feature, only select the other features that you need (ApacheDS
Configuration, LDAP Browser, LDAP Servers, LDIF Editor, Schema Editor).

> My environment is Java 1.6, Eclipse Kepler.  I've also tried it on Java 1.8 Eclipse Luna.
 Same results either case.

Studio currently won't work in Luna, so please try with Kepler.

Kind Regards,
Stefan

\

Mime
View raw message