directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Lécharny <elecha...@gmail.com>
Subject Re: AD M16 and Studio M2: deleting ACI generates error
Date Tue, 25 Mar 2014 21:09:04 GMT
Le 3/25/14 9:58 PM, Pierre Smits a écrit :
> The content is:
>
> dn: cn=orrtizAuthReqACISubEntry,dc=orrtiz,dc=com
> objectClass: top
> objectClass: accessControlSubentry
> objectClass: subentry
> cn: orrtizAuthReqACISubEntry
> prescriptiveACI: { identificationTag "directoryManagerFullAccessACI", preced
>  ence 11, authenticationLevel simple, itemOrUserFirst userFirst: { userClass
>  es { name { "cn=nl04748,ou=users,dc=orrtiz,dc=com" } }, userPermissions { {
>   protectedItems { allUserAttributeTypesAndValues, entry }, grantsAndDenials
>   { grantReturnDN, grantFilterMatch, grantBrowse, grantCompare, grantAdd, gr
>  antInvoke, grantModify, grantImport, grantDiscloseOnError, grantRename, gra
>  ntRemove, grantRead, grantExport } } } } }
> prescriptiveACI: { identificationTag "allUsersACI", precedence 10, authentic
>  ationLevel none, itemOrUserFirst userFirst: { userClasses { allUsers }, use
>  rPermissions { { protectedItems { allUserAttributeTypesAndValues, entry },
>  grantsAndDenials { grantReturnDN, grantFilterMatch, grantBrowse, grantCompa
>  re, grantDiscloseOnError, grantRead } }, { protectedItems { attributeType {
>   userPassword } }, grantsAndDenials { denyRead, denyFilterMatch, denyCompar
>  e } } } } }
> subtreeSpecification: { base "dc=orrtiz,dc=com" }
> accessControlSubentries: 2.5.4.3=orrtizacisubentry,0.9.2342.19200300.100.1.2
>  5=orrtiz,0.9.2342.19200300.100.1.25=com
> createTimestamp: 20140325182443.296Z
> creatorsName: 0.9.2342.19200300.100.1.1=admin,2.5.4.11=system
> entryCSN: 20140325200009.087000Z#000000#001#000000
> entryDN: cn=orrtizAuthReqACISubEntry,dc=orrtiz,dc=com
> entryParentId: a22442b4-f41f-46bb-89d8-e567ed1a5800
> entryUUID:: MWViMTQxMDktNzEzOC00NzFkLTlmYzEtZTgyMTM1NzI1ZDU1
> modifiersName: 0.9.2342.19200300.100.1.1=admin,2.5.4.11=system
> modifyTimestamp: 20140325200009.087Z



That's weird... The subtreeSpecification is not null, not is its base,
you should not get the NPE you have had...

At this point, I'll need to have a test case to reproduce this problem,
in order to find the bug.

Can you provide the elements that led to this situation ? (preferably in
a JIRA)

Thanks !

-- 
Regards,
Cordialement,
Emmanuel Lécharny
www.iktek.com 


Mime
View raw message