directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marcel Weinberg" <mweinberg...@email.de>
Subject ApacheDS Server - unable to listen on UDP
Date Tue, 11 Feb 2014 22:17:47 GMT


Hi all, 
 
I need help configuring the UDP listener on our ApacheDS server configuration. I spend many
hours reading documentation and trying it again and again and again ... and again... without
success...
 
Purpose:
Some clients (running Windows 7 on Laptops e.g.) in our network prefer UDP for ldap requests.
So I would like to create a 2nd listener that is also listening on port 389 but using UDP
as protocol.
 
Let's see what I've done during my recent test:
ads-transportid=ldap,ou=transports,ads-serverId=ldapServer,ou=servers,ads-directoryServiceId=default,ou=config
- we only changed the port on this entry to 389 and it works fine running the server daemon
as root. The server is listening on port 389 / TCP now.
 
Now, I created ads-transportId=udp,ou=transports,ads-serverId=ldapServer,ou=servers,ads-directoryServiceId=default,ou=config.
The respective root.ldif sections looks like this:
 

dn: ads-transportId=udp,ou=transports,ads-serverId=ldapServer,ou=servers,ads-dir
 ectoryServiceId=default,ou=config
ads-transportaddress: 0.0.0.0
ads-transportid: udp
ads-transportnbthreads: 8
entryParentId: 0a65525a-9f59-4cb2-8144-1bf6ca281adb
ads-systemport: 389
createtimestamp: 20140207150624.890Z
ads-enabled: TRUE
objectclass: ads-transport
objectclass: ads-base
objectclass: ads-udpTransport
objectclass: top
entryuuid: 2ac89a8c-a19e-42ce-b1b1-19e29482b854
creatorsname: 0.9.2342.19200300.100.1.1=admin,2.5.4.11=system
entrycsn: 20140210105851.235000Z#000000#001#000000
modifytimestamp: 20140210105851.235Z
modifiersname: 0.9.2342.19200300.100.1.1=admin,2.5.4.11=system
 
 
Is there any error or did I forget something? I restarted the daemon but it's still not listening
on UDP. This was confirmed by checking netstat and trying to connect with a Win7 laptop for
example that uses UDP. It's still listening fine on TCP.
 
The only hint I get from the logfiles is the following:
wrapper.log:INFO   | jvm 1    | 2014/02/11 23:01:44 | [23:01:44] WARN [org.apache.directory.server.ldap.LdapServer]
- Cannot listen on an UDP transport : UdpTransport[<0.0.0.0:389>], backlog=50, nbThreads
= 8]
 
But I have no idea WHY this message appears. The daemon is executed by root and the service
itself is also running as root. This issue is reproducable on CentOS 6.4 and different Ubuntu
/ Debian derivates. There are no errors recored in the logfiles /var/log/messages and /var/log/syslog
during the startup of the service.
 
I ran a few more tests (removing the tcp listener, switching the port, switching between different
ips (127.0.0.1, 10.0.0.49, 0.0.0.0), etc) and finally, I ran out of ideas.
 
So, my question is:
- did anyone else experience this issue - and has a fix?
 
If not:
- is there another way to connect Windows 7 clients to the ApacheDirectory server?
 
 
 
Any help is welcome!  
 
Marcel

Mime
View raw message