directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kiran Ayyagari <kayyag...@apache.org>
Subject Re: Multi-Master Replication Startup Question
Date Thu, 29 Aug 2013 14:22:10 GMT
Thanks Paul for reporting the issue, I have just committed the fix.



On Tue, Aug 27, 2013 at 1:21 AM, Paul Bayliss <prbayliss@me.com> wrote:

> Thank you Kiran,
>
> I've logged the bug in Jira.
>
> Best regards,
> Paul
>
> On Aug 26, 2013, at 3:26 PM, Kiran Ayyagari <kayyagari@apache.org> wrote:
>
> > this appears to be a bug due to consumers on bother servers trying to
> > connect
> > to their peers before binding to each server's local port
> >
> > can you file a bug report here[1] and attach your configurations.
> >
> > [1] https://issues.apache.org/jira/browse/DIRSERVER
> >
> >
> > On Mon, Aug 26, 2013 at 11:28 PM, Paul Bayliss <prbayliss@me.com> wrote:
> >
> >> Hi Guys,
> >>
> >> I am experimenting with Multi-Master replication of two ApacheDS
> 2.0.0.M15
> >> instances, however I have problem starting both instances as replication
> >> consumers. Instance 1 is setup to listen for LDAP requests on port 10389
> >> and instance 2 on port 11389. When the nodes start I see the following
> >> errors repeated every 5 seconds and a netstat -an | egrep "10389|11389"
> >> shows that the LDAP listening ports are not created.
> >>
> >> Instance 1:
> >>
> >> [12:58:26] ERROR [org.apache.directory.server.CONSUMER_LOG] - Failed to
> >> connect to the server localhost:11389, cause : Cannot connect on the
> >> server: Connection refused
> >> [12:58:26] ERROR
> >>
> [org.apache.directory.server.ldap.replication.consumer.ReplicationConsumerImpl]
> >> - Failed to connect to the server localhost:11389, cause : Cannot
> connect
> >> on the server: Connection refused
> >>
> >> Instance 2:
> >>
> >> [12:58:14] ERROR [org.apache.directory.server.CONSUMER_LOG] - Failed to
> >> connect to the server localhost:10389, cause : Cannot connect on the
> >> server: Connection refused
> >> [12:58:14] ERROR
> >>
> [org.apache.directory.server.ldap.replication.consumer.ReplicationConsumerImpl]
> >> - Failed to connect to the server localhost:10389, cause : Cannot
> connect
> >> on the server: Connection refused
> >>
> >> prbayliss$ netstat -a | egrep "10389|11389"
> >>
> >> I am able to trick the instances into starting up by starting instance 1
> >> without being a replication consumer, then starting instance 2. I then
> stop
> >> instance 1 change it to be a consumer and restart it. Then both
> instances
> >> are running and netstat shows me the replication connections and the
> >> listening LDAP ports. Replication now works in both directions.
> >>
> >> prbayliss$ netstat -a | egrep "10389|11389"
> >> tcp4       0      0  localhost.10389        localhost.51051
> >> ESTABLISHED
> >> tcp4       0      0  localhost.51051        localhost.10389
> >> ESTABLISHED
> >> tcp46      0      0  *.10389                *.*
>  LISTEN
> >> tcp4       0      0  localhost.11389        localhost.51050
> >> ESTABLISHED
> >> tcp4       0      0  localhost.51050        localhost.11389
> >> ESTABLISHED
> >> tcp46      0      0  *.11389                *.*
>  LISTEN
> >>
> >> I've attached both configuration files. Is there a configuration option
> >> that I'm missing?
> >>
> >> Many thanks in advance,
> >> Paul
> >>
> >>
> >
> >
> > --
> > Kiran Ayyagari
> > http://keydap.com
>
>


-- 
Kiran Ayyagari
http://keydap.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message