directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pierre-Arnaud Marcelot ...@marcelot.net>
Subject Re: Unable to save configuration file
Date Tue, 20 Aug 2013 17:16:00 GMT
Thanks.

Did you refresh the Modifications Logs view right after you got the error?
For some reason the view does not get updated when the error occurs, hence my indication in
the previous mail to first clear and then refresh the view.

The other error, reported by the editor, isn't much helpful unfortunately.

Regards,
Pierre-Arnaud
 
On 19 août 2013, at 22:29, Merve Temizer <mervet2009@gmail.com> wrote:

> Pierre-Arnaud, thanks very much for response.
> 
> I cleared Modification Logs view, and restarted the server and try again to
> save configuration, i got error alert but could not see nothing on
> Modification Logs.
> 
> At a previous reply i am told that in my old Modification Logs, in a point
> of error, server tells me there is no partition in my old Modification
> Logs, but i was trying to configure server to define a brand new partition.
> That mentioned Modification Logs error point was a trial of mine that i try
> to add an entry without configuration.
> 
> Below is error alert window:
> 
> Unable to save configuration.
> - Changes could not be saved to the connection.
> java.lang.Exception: Changes could not be saved to the connection.
> at
> org.apache.directory.studio.apacheds.configuration.v2.editor.ServerConfigurationEditorUtils.saveConfiguration(ServerConfigurationEditorUtils.java:374)
> at
> org.apache.directory.studio.apacheds.configuration.v2.jobs.SaveConfigurationRunnable.run(SaveConfigurationRunnable.java:118)
> at
> org.apache.directory.studio.common.core.jobs.StudioJob.run(StudioJob.java:83)
> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)
> 
> Changes could not be saved to the connection.
> 
> 
> 2013/8/19 Pierre-Arnaud Marcelot <pa@marcelot.net>
> 
>> The modifications logs you sent is a bit messy with a lot of tries on your
>> side which makes it difficult to isolate the ones from the configuration
>> plugin from which you're getting the error.
>> 
>> Would you mind clearing the modifications logs, retrying and give us back
>> only the information related to the failed save attempt thanks.
>> 
>> 
>> On the context entry creation in the page, the documentation is a bit
>> outdated.
>> In recent versions of ApacheDS we've re-introduced the ability to
>> auto-generate the context entry, so that part in the documentation can be
>> skipped (and we need to update it to reflect the current state of the
>> server).
>> 
>> Regards,
>> Pierre-Arnaud
>> 
>> 
>> On 19 août 2013, at 13:53, Merve Temizer <mervet2009@gmail.com> wrote:
>> 
>>> But i follow the instruction on below page, it starts with configuration
>> of
>>> server. Am i wrong?
>>> 
>>> 
>> http://directory.apache.org/apacheds/basic-ug/1.4.3-adding-partition.html
>>> 
>>> 
>>> 2013/8/19 Kiran Ayyagari <kayyagari@apache.org>
>>> 
>>>> On Mon, Aug 19, 2013 at 2:40 PM, Merve Temizer <mervet2009@gmail.com>
>>>> wrote:
>>>> 
>>>>> Here is modification logs:
>>>>> 
>>>>> <snip/>
>>>> 
>>>>> #!RESULT ERROR
>>>>> #!CONNECTION ldap://localhost:10389
>>>>> #!DATE 2013-08-18T16:07:10.916
>>>>> #!ERROR [LDAP: error code 32 - NO_SUCH_OBJECT: failed for MessageType
:
>>>>> ADD_REQUEST Message ID : 14 Add Request : Entry dn[n]: dc=merve,dc=com
>>>>> objectclass: top objectclass: organizationalUnit objectclass:
>>>>> ****Organization dc: merve ou: merve description: The System context
>>>> entry
>>>>> : ERR_268 Cannot find a partition for dc=merve,dc=com]
>>>>> 
>>>> the error is quite self descriptive, the parition dc=merve,dc=com
>> partition
>>>> doesn't exist
>>>> 
>>>>> dn: dc=merve,dc=com
>>>>> changetype: add
>>>>> dc: merve
>>>>> ou: merve
>>>>> objectclass: top
>>>>> objectclass: organizationalUnit
>>>>> objectclass: ****Organization
>>>>> description: The System context entry
>>>>> 
>>>>> 
>>>>> 
>>>>> 2013/8/18 Merve Temizer <mervet2009@gmail.com>
>>>>> 
>>>>>> I must know where should i delete the data that my old server save.
>> But
>>>>> at
>>>>>> connection browser i do not see the data it seems brand new
>>>>>> 
>>>>>> 
>>>>>> 2013/8/18 Merve Temizer <mervet2009@gmail.com>
>>>>>> 
>>>>>>> 
>>>>>>> Hi,
>>>>>>> Thanks for replies,
>>>>>>> 
>>>>>>> When i look at the modification logs i see data from my old server.
>>>>>>> 
>>>>>>> The story:
>>>>>>> 
>>>>>>> There was a server which i build from source and run in eclipse,
>>>>>>> 
>>>>>>> in that old server there was partitions context entries, users
etc, i
>>>>> was
>>>>>>> able to connect to it with eclipse LDAP browser.
>>>>>>> 
>>>>>>> I deleted all that projects and source, checked out apacheds
from
>>>> trunk
>>>>>>> 
>>>>>>> imported into eclipse build with maven and run, and saw in browser
>>>> that
>>>>>>> it is default tree, my entries arent there as i expected.
>>>>>>> 
>>>>>>> But now in modification log i see data about my old server. I
think i
>>>>> can
>>>>>>> not add new partition because the old server has a partition
with
>> same
>>>>>>> name.
>>>>>>> 
>>>>>>> 
>>>>>>> 
>>>>>> 
>>>>> 
>>>> 
>>>> 
>>>> 
>>>> --
>>>> Kiran Ayyagari
>>>> http://keydap.com
>>>> 
>> 
>> 


Mime
View raw message