directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dorninger Klaus <Klaus.Dornin...@itsv.at>
Subject Maven-Dependency for DS 2.0.0-M14 cannot be resolved
Date Mon, 08 Jul 2013 13:29:27 GMT
Hi,

I'm trying to get ApacheDS 2.0.0-M14 working in a maven project using the following configuration
in my pom file:

...
  <properties>
    <version.org.apache.directory.server>2.0.0-M14</version.org.apache.directory.server>
  </properties>
...

...
      <dependency>
        <groupId>org.apache.directory.server</groupId>
        <artifactId>apacheds-core</artifactId>
        <version>${version.org.apache.directory.server}</version>
      </dependency>
      <dependency>
        <groupId>org.apache.directory.server</groupId>
        <artifactId>apacheds-protocol-ldap</artifactId>
        <version>${version.org.apache.directory.server}</version>
      </dependency>
...

This however results in the following error:
Failed to execute goal on project xxx: Could not resolve dependencies for project xxx:yyy:jar:1.0.0-SNAPSHOT:
The following artifacts could not be resolved: org.apache.directory.jdbm:apacheds-jdbm1:bundle:2.0.0-M2

Our local maven nexus cannot find the artifact org.apache.directory.jdbm:apacheds-jdbm1:bundle:2.0.0-M2.
I tried to find it on maven central but it's not there either. http://repo1.maven.org/maven2/org/apache/directory/jdbm/apacheds-jdbm1/2.0.0-M2/apacheds-jdbm1-2.0.0-M2.bundle
results in 404.

What am I doing wrong or is there some error in the distribution of apacheds artifacts to
the maven repository?

Regards,
Klaus

__________________________________________

Klaus Dorninger, BA
IT-Services der Sozialversicherung GmbH
Bereich Software
Enterprise Content Management
ePortal Entwickler
Johann-Böhm-Platz 1
A-1020 Wien
T: +43 (0) 50124 844 1271
M: +43 (0) 664 88 66 1271
klaus.dorninger@itsv.at
www.itsv.at | www.intranet.itsv.at


Mime
View raw message