directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Olivier Drouin <ol.dro...@gmail.com>
Subject Re: [Studi] OpenLDAP cn=config browser issue
Date Mon, 08 Jul 2013 13:44:53 GMT
Studio is  Version: 2.0.0.v20130517
Openldap is 2.4.35 compiled with:  ./configure --prefix=/usr/local
--enable-modules --enable-overlays=mod


Thank you.


On Mon, Jul 8, 2013 at 9:27 AM, Emmanuel Lécharny <elecharny@gmail.com>wrote:

> Le 7/8/13 2:41 PM, Olivier Drouin a écrit :
> > Hello!
> >           I encountered a weird issue on my setup lately and I'm not sure
> > what I did to break things.
> >           I used to be able to browse and modify the cn=config OpenLDAP
> > tree within Studio.
> >
> >           I think the issue is with Studio because I can modify the
> > cn=config tree with ldapmodify using the RootDN of the config database.
> >
> > For example:
> >
> > $ cat setRO.ldif
> > # set a bd read-only
> > dn: olcDatabase={2}bdb,cn=config
> > changetype: modify
> > replace: olcReadOnly
> > olcReadOnly: TRUE
> >
> > $ ldapmodify -W -D cn=Manager,cn=config  -f setRO.ldif
> > Enter LDAP Password:
> > modifying entry "olcDatabase={2}bdb,cn=config"
> >
> >            .... but if I connect with cn=Manager,cn=config  with Studio I
> > no longer see the cn=config tree under the Root DSE. As I said earlier,
> it
> > used to work but I'm not sure what I did to break things, any idea ?
> Open LDAP version ? Studio version ?
>
>
> --
> Regards,
> Cordialement,
> Emmanuel Lécharny
> www.iktek.com
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message