directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tayler M. Albitz" <albi...@rcn.com>
Subject Re: [ApacheDS] - Simple example for the ACI subsystem not working
Date Wed, 24 Jul 2013 17:41:57 GMT
Yes, ads-dsaccesscontrolenabled value is set to TRUE and the LDAP server has been restarted.


I also ended up breaking up the LDIF file in the tutorials example and was able to get enough
working to test. The same result occurred. I can connect, but not see anything but the root
dse . 

I also tested this out on a later version in case there was a bug. Same issue on apacheds
2.0.0-M11 w/ Studio v2.0.0 v20130308 . 

Any other thoughts? Were you able to review the document provided with my screenshots? Did
everything look okay? 

One thing I tried different on the second setup was previously I was creating more than one
prescriptiveaci entry. This time, I created a single entry add just added additional values.


Could you possibly provide an export to LDIF of this from your environment where it is working?
As well as confirm the version you successfully completed this on? 

Thanks, 
-Tayler 

----- Original Message -----

From: "Kiran Ayyagari" <kayyagari@apache.org> 
To: users@directory.apache.org 
Sent: Monday, July 22, 2013 3:34:12 AM 
Subject: Re: [ApacheDS] - Simple example for the ACI subsystem not working 

On Mon, Jul 22, 2013 at 6:07 AM, Tayler M. Albitz <albitzt@rcn.com> wrote: 

> 
> Hi Kiran, 
> 
> Thanks so much for the reply. I'm not sure what I'm missing, other than 
> probably user error (as I am new to apacheds). I have created a word 
> document with screenshots, can you give it a look please? 
> 
> did you change the ads-dsaccesscontrolenabled value to TRUE in the entry 
ads-directoryServiceId=default,ou=config and restart the server? 

> Link to screenshots: 
> http://www.filedropper.com/apachedsauthorization 
> 
> Also, the LDIF file (provided in the tutorial) doesn't work for me either. 
> I figured I would reverse engineer it to figure my issue, but it yields the 
> following error: 
> 
> check for any unwanted new lines that were introduced during copy-paste 

> Error while importing LDIF 
> - Record is invalid: Unexpected Token 
> javax.naming.NamingException: Record is invalid: Unexpected Token 
> at 
> org.apache.directory.studio.ldapbrowser.core.jobs.ImportLdifRunnable.importLdifRecord(ImportLdifRunnable.java:409)

> at 
> org.apache.directory.studio.ldapbrowser.core.jobs.ImportLdifRunnable.importLdif(ImportLdifRunnable.java:272)

> at 
> org.apache.directory.studio.ldapbrowser.core.jobs.ImportLdifRunnable.run(ImportLdifRunnable.java:218)

> at 
> org.apache.directory.studio.connection.core.jobs.StudioConnectionJob.run(StudioConnectionJob.java:109)

> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54) 
> 
> Record is invalid: Unexpected Token 
> 
> Thanks again, 
> -Tayler 
> 
> 


-- 
Kiran Ayyagari 
http://keydap.com 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message