directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kiran Ayyagari <kayyag...@apache.org>
Subject Re: How to enable SSL for LDAP with Apache Directory Studio?
Date Tue, 14 May 2013 07:38:01 GMT
if all that you are trying to do is testing ldaps:// then just connect
directly to server, no need to setup your own certificate unless you want
to replace the existing one with your own CA or other self signed
certificate


On Tue, May 14, 2013 at 12:51 PM, Ashwin Kumar <ashwinkumark10@gmail.com>wrote:

> I am using Apache Directory Studio for testing LDAP services for an
> application. I am lost in configuring the LDAP with SSL.
>
> So far I've tried:
>
>    1. Started ApacheDS with port 10389 (ldap://) and also on 10636
>    (ldaps://)
>
> Here's the screenshot of ldap config in Apache Directory studio:
>
>
> [image: Inline image 1]
>
>
> Then I followed the instructions as mentioned here: How to enable SSL<http://directory.apache.org/apacheds/basic-ug/3.3-enabling-ssl.html>
>
> I generated the keys using keytool<http://docs.oracle.com/javase/6/docs/technotes/tools/windows/keytool.html>
> :
>
> C:\LDAP\keys>keytool -genkey -keyalg "RSA" -dname "
> mojo,cn=com" -alias mojo -keystore mojo1.ks -storepass secret -validity 3650
>
> and then I am using this key in Apache Directory Studio (and restarting
> the LDAP server), I end up with this error:
>
>
> [image: Inline image 2]
>
>
> Can someone tell what I am doing wrong? Is there something I am missing?
>
> --
> Ashwin kumar
> (http://ashwinkumar.me)
>
>


-- 
Kiran Ayyagari
http://keydap.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message