directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Lécharny <elecha...@gmail.com>
Subject Re: Upgrade from ApacheDS 1.5.3 to 2.0
Date Wed, 22 May 2013 17:21:55 GMT
Le 5/22/13 6:54 PM, Abdala, Pablo Javier a écrit :
>> We don't provide installers for HP Unix, so you will have to use the
> archive tarball
> (http://directory.apache.org/apacheds/download/download-archive.html)
>
> Hello Emmanuel,
>                 I´ve installed the ApachedDS, then imported the schema from 1.5.3 but
I had this error:
> #!RESULT ERROR
> #!CONNECTION ldap://dhpx0049:10389
> #!DATE 2013-05-22T12:07:52.469
> #!ERROR [LDAP: error code 68 - ENTRY_ALREADY_EXISTS: failed for MessageType : ADD_REQUEST
Message ID : 12     Add Request : Entry     dn[n]: dc=example,dc=com     objectClass: domain
    objectClass: extensibleObject     objectClass: top     dc: example : ERR_250_ENTRY_ALREADY_EXISTS
dc=example,dc=com already exists!]
> dn: dc=example,dc=com
> changetype: add
> dc: example
> objectClass: domain
> objectClass: extensibleObject
> objectClass: top

Plain normal. The example.com entry is already present by default.
>
> So I remove the Entry from the schema then imported again and I gave this error:
>
> #!RESULT ERROR
> #!CONNECTION ldap://dhpx0049:10389
> #!DATE 2013-05-22T12:57:07.935
> #!ERROR [LDAP: error code 19 - CONSTRAINT_VIOLATION: failed for MessageType : ADD_REQUEST
Message ID : 50     Add Request : Entry     dn[n]: uid=z111111,ou=users,dc=example,dc=com
    objectClass: person     objectClass: organizationalPerson     objectClass: inetOrgPerson
    objectClass: top     uid: z111111     sn: z111111     userPassword: '0x70 0x65 0x70 0x65
'     cn: z111111     displayName: z111111 : Password should have a minmum of 5 characters]
> dn: uid=z111111,ou=users,dc=example,dc=com
> changetype: add
> displayName: z111111
> objectClass: person
> objectClass: organizationalPerson
> objectClass: inetOrgPerson
> objectClass: top
> uid: z111111
>
> Can you identify the problem?

Yes, the passwordPolicy is enabled, and it expect your password to be at
leat 5 chars long.

Either you modify your passowrd, or you disable the PasswordPolicy (but
I suspect you wanted to migrate because the PasswordPolicy is now
handled by 2.0...)


-- 
Regards,
Cordialement,
Emmanuel Lécharny
www.iktek.com 


Mime
View raw message