directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patricio Demitrio <pdemit...@scoop-gmbh.de>
Subject Re: pwdHistory not validating properly (in custom server)
Date Tue, 30 Apr 2013 15:37:38 GMT
Please try something if you have a couple of minutes.

Grab the code from AuthenticationInterceptor.java, create a new class, for
example, AuthenticationInterceptor2.java, and copy it.

Changes needed in order to compile:
import AuthenticationInterceptor
change "extends Base..." for "extends AuthenticatorInterceptor"
fix the super call in the constructor.

If I'm not wrong, that should compile for you. Now, instead of including
AuthenticationInterceptor in your DirectoryService, please include
AuthenticationInterceptor2.

That should start your server normally. And that should give you the error.

Another example for forcing the error: the class
AuthenticationInterceptor2, instead of being a duplicate
of AuthenticationInterceptor, is created with only this:

import org.apache.directory.api.ldap.model.exception.LdapException;
import
org.apache.directory.server.core.api.interceptor.context.ModifyOperationContext;
import org.apache.directory.server.core.authn.AuthenticationInterceptor;

public class AuthenticationInterceptor2 extends AuthenticationInterceptor{

public void modify( ModifyOperationContext modifyContext ) throws
LdapException
    {
super.modify(modifyContext);
    }
}

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message