directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pierre-Arnaud Marcelot ...@marcelot.net>
Subject Re: Any hints on whether ApacheDS 2.0M8 run on Solaris?
Date Tue, 11 Dec 2012 22:19:55 GMT
ApacheDS 2.x requires Java 6 or better.

That's why you're getting this error.

Regards,
Pierre-Arnaud


On 11 déc. 2012, at 23:15, "Zhang, Wayne" <wzhang@visa.com> wrote:

> I will download that one and try.
> 
> java version "1.5.0_13"
> Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_13-b05)
> Java HotSpot(TM) Server VM (build 1.5.0_13-b05, mixed mode)
> 
> Wayne
> 
> -----Original Message-----
> From: Pierre-Arnaud Marcelot [mailto:pajbam@gmail.com] On Behalf Of Pierre-Arnaud Marcelot
> Sent: Tuesday, December 11, 2012 2:14 PM
> To: users@directory.apache.org
> Subject: Re: Any hints on whether ApacheDS 2.0M8 run on Solaris?
> 
> Yeah, I think the Linux binary installer should work (at least it's worth a try).
> 
> What version of Java are you using ?
> 
> Regards,
> Pierre-Arnaud
> 
> 
> On 11 déc. 2012, at 23:10, "Zhang, Wayne" <wzhang@visa.com> wrote:
> 
>> Thank you.
>> 
>> Were you saying that Linux installer also work on Solaris?
>> 
>> I tried the tar.gz archive. It could not be run on Solaris since it complained about:
>> 
>> "java.lang.UnsupportedClassVersionError: Bad version number in .class file"
>> 
>> Which usually is generated when I used jar file compiled on a different platform.
>> 
>> Any hints?
>> 
>> Thanks.
>> 
>> Wayne
>> 
>> -----Original Message-----
>> From: Pierre-Arnaud Marcelot [mailto:pajbam@gmail.com] On Behalf Of Pierre-Arnaud
Marcelot
>> Sent: Tuesday, December 11, 2012 2:06 PM
>> To: users@directory.apache.org
>> Subject: Re: Any hints on whether ApacheDS 2.0M8 run on Solaris?
>> 
>> Hi Wayne,
>> 
>> Yes it will run on Solaris.
>> 
>> We dropped support for the native installer for Solaris but you can use the Linux
binary installer or the zip or tar.gz archive if you like.
>> 
>> Hope this helps,
>> Pierre-Arnaud
>> 
>> On 11 déc. 2012, at 23:00, "Zhang, Wayne" <wzhang@visa.com> wrote:
>> 
>>> 
>>> Can anyone give me a hint whether 2.0.0M8 will run on Solaris? 
>>> 
>>> I could not find the installer on your site for the platform. If it can, it is
worthy to spend time to figure out how to build it from source code. 
>>> 
>>> Thanks.
>>> 
>>> Wayne
>>> 
>> 
> 


Mime
View raw message