directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pierre-Arnaud Marcelot ...@marcelot.net>
Subject Re: Unable to uninstall 2.0.0M8 on Mac OSX Mountain Lion
Date Fri, 23 Nov 2012 09:20:36 GMT
Hi Tony,

OS X keeps receipt files of the previous installation and checks the version number before
installing a new one.

These receipts files can be removed with the following command:
> sudo rm -rf /var/db/receipts/org.apache.directory.server.*


We will try to provide a shell script in the next version automatically clean everything.

Regards,
Pierre-Arnaud

On 23 nov. 2012, at 06:05, Tony Obermeit <tony@tamborine.to> wrote:

> Looking for help to uninstall apache directory server.
> 
> I've been using 1.5.5 on another machine succesfully, set up new machine
> with 2.0.0M8 but it works differently so I wanted to uninstall 2.0 and
> install 1.5.7
> 
> I removed these files
> 
> /Library/LaunchDeamons/org.apache.directory.server.plist
> /usr/local/apacheds-2.0.0-M8  (removed entire directory)
> /usr/bin/apacheds
> 
> I tried to install 1.5.7 but get the error: "Apache Directory Server
> 1.5.7can't be installed on this disk.  A newer version of this software
> already exists on this system."
> 
> Any help would be appreciated, I've spent several hours with google
> searches and apache jira forum searches with no luck for the solution.


Mime
View raw message