directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kiran Ayyagari <kayyag...@apache.org>
Subject Re: Possible regression for substring search on indexes?
Date Thu, 18 Oct 2012 03:14:28 GMT
On Thu, Oct 18, 2012 at 3:24 AM, Emmanuel Lécharny <elecharny@gmail.com> wrote:
> Le 10/17/12 11:10 PM, Carlo.Accorsi@ibs-ag.com a écrit :
>
>> Hi, All - I've rebuilt from the trunk this morning twice and loaded our
>> users from scratch.
>>
>> The out of memory errors are gone, thank you but now we don't get results
>> of any kind, seemingly under any circumstances when doing a substring
>> search.
>> I get instant results when doing an exact match but the substring searches
>> are not working.
>>
>> sn=Smith
>>
>> However,
>> sn=Smit*
>>
>> The result comes back (0, filtered) from Studio.
>>
>> At one point there were some corrections to normalize data (to lowercase)
>> in the indexes. I tested searching against
>>
>> sn=smit*
>>
>> after saving the field back to 'smith' and still no results.
>>
>> I check out from here.  Is this where I should? Thanks!
>> svn checkout
>> http://svn.apache.org/repos/asf/directory/apacheds/trunk-with-dependencies
>
> This link or http://svn.apache.org/repos/asf/directory/trunks/
>
> but you will get the same sources.
>
> Ths is quite strange, as the tests I conducted shown that the substring
> filter was correctly returning the right values...
>
> I have added a test that demonstrate the subsctring search works on indexed
> attributes :
>
> http://svn.apache.org/viewvc?rev=1399450&view=rev
>
> Can you test that this test works for you ?
>
> Sady, I'm MIA for a few days, with little internet connection and time to
> check that. Kiran or Pierre-Arnaud, you may give me an hand while I'm not
> around ?
>
sure, count on us :)
> Thanks !
>
>
> --
> Regards,
> Cordialement,
> Emmanuel Lécharny
> www.iktek.com
>



-- 
Kiran Ayyagari
http://keydap.com

Mime
View raw message