directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <Carlo.Acco...@ibs-ag.com>
Subject RE: Possible regression for substring search on indexes?
Date Tue, 16 Oct 2012 13:05:44 GMT
OK thanks for the quick response. I've built and tested (revision 1398757) but is still taking
several minutes to return substring search. I'm doing my searching via Studio and have exclusive
access
To the directory. Interestingly, it somehow knows that count right away but doesn't return
anything for several mintues. 

I just swapped out the jar (with the one from a week ago) in this case bc I was hoping to
validate the test without needing to rebuild and re-import all the users. 
I would rebuild everything before for production but to test this correction, do I need to
do this? 

Also, months ago we had an explicit index on entryUUID but we removed it when we didn't see
it in the stock config.ldif. 
entryCSN does have an index. 

These are the indexed attrs on the partition. After the ldif import they all had grown in
size (on disk) so I'm fairly confident they're being populated. 
Are we missing any that would work in conjunction with index searches? Thanks!

apacheRdn
apacheSubLevel
apachePresence
apacheOneLevel
apacheOneAlias
apacheSubAlias
apacheAlias
entryCSN
o
krb5PrincipalName
objectClass
ou
uid
employeeNumber
displayName
cn
mail
roomNumber
pwdPolicySubEntry
member
description
givenName
sn
administrativeRole


Regards,
Carlo Accorsi

-----Original Message-----
From: Emmanuel Lécharny [mailto:elecharny@gmail.com] 
Sent: Tuesday, October 16, 2012 7:33 AM
To: users@directory.apache.org
Subject: Re: Possible regression for substring search on indexes?

Le 10/15/12 11:52 PM, Carlo.Accorsi@ibs-ag.com a écrit :
> Hi, we're using M9 built from the trunk on Wednesday of last week. We have our db setup
as it has been for the past several months. There are 80k users.
>
> (sn=Thompson)  returns in miliseconds
> (sn=Thompso*)  returns after 3-4 minutes.
>
> This seems very much like an issue we had back and in June (and was fixed).  Any help
is most appreciated. We need this build for all the good work Karin did on the password policy.
>
> Thank you, Carlo Accorsi
>
It should be fixed with http://svn.apache.org/viewvc?rev=1398737&view=rev

Can you give it a try ?

-- 
Regards,
Cordialement,
Emmanuel Lécharny
www.iktek.com

Mime
View raw message