directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wang, Xunhua - wangxx" <wan...@jmu.edu>
Subject RE: [ERROR] Failed to execute goal on project apacheds-all: Could not resolve dependencies for project org.apache.directory.server:apacheds-all:jar:2.0.0-M7-SNAPSHOT: Could not find artifact
Date Thu, 01 Mar 2012 19:24:59 GMT
Thank you.

In my case, upgrading JDK to 1.6.0_30 does _not_ help. Still got the following error:

+++++ ERROR BEGINS +++++
[ERROR] Failed to execute goal on project apacheds-all: Could not resolve dependencies for
project org.apache.directory.server:apacheds-all:jar:2.0.0-M7-SNAPSHOT: Could not find artifact
org.apache.directory.jdbm:apacheds-jdbm2:bundle:2.0.0-M2-SNAPSHOT in apache.snapshots (https://repository.apache.org/content/repositories/snapshots/)
-> [Help 1]
org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal on project
apacheds-all: Could not resolve dependencies for project org.apache.directory.server:apacheds-all:jar:2.0.0-M7-SNAPSHOT:
Could not find artifact org.apache.directory.jdbm:apacheds-jdbm2:bundle:2.0.0-M2-SNAPSHOT
in apache.snapshots (https://repository.apache.org/content/repositories/snapshots/)
        at org.apache.maven.lifecycle.internal.LifecycleDependencyResolver.getDependencies(LifecycleDependencyResolver.java:210)
        at org.apache.maven.lifecycle.internal.LifecycleDependencyResolver.resolveProjectDependencies(LifecycleDependencyResolver.java:117)
        at org.apache.maven.lifecycle.internal.MojoExecutor.ensureDependenciesAreResolved(MojoExecutor.java:258)
        at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:201)
        at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
        at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
        at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
        at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
        at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
        at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
        at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:320)
        at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
        at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
        at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
        at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
        at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
        at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
        at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
+++++ ERROR ENDS +++++

Adding  -U to maven does not help either.

Steve
________________________________________
From: Emmanuel Lécharny [elecharny@gmail.com]
Sent: Thursday, March 01, 2012 1:17 PM
To: users@directory.apache.org
Subject: Re: [ERROR] Failed to execute goal org.apache.maven.plugins:maven-shade-plugin:1.5:shade
(default) on project shared-all: Error creating shaded jar: error in opening zip file C:\tmp\apacheds\apacheds-trunk\shared\all\target\shared-all-1.0.0-M12-SNAPSHO...

Le 3/1/12 6:42 PM, Wang, Xunhua - wangxx a écrit :
> Just downloaded mvn, checked out apacheds-trunk on Ubuntu 10 (with jdk 1.6.0_20), ran
the following command, and got this error:

1.6.0_20 is *really* old.

I just tested on Ubuntu 11.10, with Java 1.6.0-29, it builds.

Note that I get a failure with Java 7 (the same than the one you've got).

May I suggest you fill a JIRA describing the failure ? I think we should
get rid of this shade-plugin error on windows...

Thanks !

--
Regards,
Cordialement,
Emmanuel Lécharny
www.iktek.com


Mime
View raw message