directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pierre-Arnaud Marcelot ...@marcelot.net>
Subject Re: Apache Directory Studio 2.0 M1
Date Fri, 20 Jan 2012 22:12:03 GMT

On 20 janv. 2012, at 22:45, Bill MacAllister wrote:

> 
> 
> --On Friday, January 20, 2012 10:14:26 PM +0100 Pierre-Arnaud Marcelot <pajbam@gmail.com>
wrote:
> 
>> Le 20 janv. 2012 à 21:25, Bill MacAllister <whm@stanford.edu> a écrit :
>> 
>>> --On Friday, January 20, 2012 07:52:14 AM +0100 Emmanuel Lecharny <elecharny@gmail.com>
wrote:
>>> 
>>>> On 1/19/12 11:48 PM, Bill MacAllister wrote:
>>>>> I just downloaded ADS 2.0 on my MacBook and tried binding to our directory
>>>>> servers
>>>>> using GSSAPI.  I am getting the following error.
>>>>> 
>>>>> Error while opening connection
>>>>> - javax.security.auth.login.LoginException: Could not load configuration
>>>>> from SCDynamicStore
>>>>> org.apache.directory.shared.ldap.model.exception.LdapException:
>>>>> javax.security.auth.login.LoginException: Could not load configuration
from
>>>>> SCDynamicStore
>>>>>   at
>>>>> org.apache.directory.ldap.client.api.LdapNetworkConnection.bindAsync(LdapNetworkConnection.java:1595)
>>>>>   at
>>>>> org.apache.directory.ldap.client.api.LdapNetworkConnection.bind(LdapNetworkConnection.java:1487)
>>>>>   at
>>>>> org.apache.directory.studio.connection.core.io.api.DirectoryApiConnectionWrapper$2.run(DirectoryApiConnectionWrapper.java:438)
>>>>>   at
>>>>> org.apache.directory.studio.connection.core.io.api.DirectoryApiConnectionWrapper.runAndMonitor(DirectoryApiConnectionWrapper.java:1161)
>>>>>   at
>>>>> org.apache.directory.studio.connection.core.io.api.DirectoryApiConnectionWrapper.doBind(DirectoryApiConnectionWrapper.java:451)
>>>>>   at
>>>>> org.apache.directory.studio.connection.core.io.api.DirectoryApiConnectionWrapper.bind(DirectoryApiConnectionWrapper.java:299)
>>>>>   at
>>>>> org.apache.directory.studio.connection.core.jobs.OpenConnectionsRunnable.run(OpenConnectionsRunnable.java:114)
>>>>>   at
>>>>> org.apache.directory.studio.connection.core.jobs.StudioConnectionJob.run(StudioConnectionJob.java:109)
>>>>>   at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
>>>>> Caused by: javax.security.auth.login.LoginException: Could not load
>>>>> configuration from SCDynamicStore
>>>>>   at
>>>>> com.sun.security.auth.module.Krb5LoginModule.login(Krb5LoginModule.java:486)
>>>>>   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>>>>>   at
>>>>> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>>>>>   at
>>>>> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>>>>>   at java.lang.reflect.Method.invoke(Method.java:597)
>>>>>   at javax.security.auth.login.LoginContext.invoke(LoginContext.java:769)
>>>>>   at javax.security.auth.login.LoginContext.access$000(LoginContext.java:186)
>>>>>   at javax.security.auth.login.LoginContext$4.run(LoginContext.java:683)
>>>>>   at java.security.AccessController.doPrivileged(Native Method)
>>>>>   at javax.security.auth.login.LoginContext.invokePriv(LoginContext.java:680)
>>>>>   at javax.security.auth.login.LoginContext.login(LoginContext.java:579)
>>>>>   at
>>>>> org.apache.directory.ldap.client.api.LdapNetworkConnection.bindAsync(LdapNetworkConnection.java:1582)
>>>>> 
>>>>> I have a valid Kerberos ticket and ldapsearch binds just fine.  Am I
>>>>> missing something?  What should
>>>>> I try next?
>>>> 
>>>> Can you try with a JNDI based connection ?
>>> 
>>> I get pretty much the same error if I use JNDI.  Attached are the
>>> error messages I am seeing.
>> 
>> Interesting. The API doesn't seem to be the cause of the error then,
>> but rather the JVM.
>> 
>> Another question, was everything working correctly with Studio version 1.5.3?
> 
> I had not installed 1.5 on my MacBook.  I did try to answer that
> question, but I am a rank user of OS X and I couldn't get 1.5.7
> installed next to 2.0.  I will try and improve my OS X skills and see
> if I can get an answer over the weekend.

Hehe, I see.
You can try to rename the 2.0 version of Studio as "Apache Directory Studio 2.0" and try to
install (via drag&drop on the 'Applications' folder) the 1.5.3 version.
This way you'll have both applications in your Applications folder.

Hope this helps,
Pierre-Arnaud


> Bill
> 
>> Regards,
>> Pierre-Arnaud
>> 
>>> Bill
>>> 
>>> --
>>> 
>>> Bill MacAllister
>>> Infrastructure Delivery Group, Stanford University
>>> <ads-connection-errors.txt>
> 
> 
> 
> -- 
> 
> Bill MacAllister
> Infrastructure Delivery Group, Stanford University
> 


Mime
View raw message