directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kiran Ayyagari <kayyag...@apache.org>
Subject Re: Custom schema objects
Date Tue, 10 Jan 2012 12:47:20 GMT
to mention it quickly, new schema elements cannot be registered using
connection.loadSchema()
you need to upload the new schema elements to the server.

Please search the ML, this was already answered before.


On Tue, Jan 10, 2012 at 5:50 PM, Christoph Czurda
<hasnoadditives@gmail.com> wrote:
> Hi,
>
> How can I use custom schema objects in my own application with ApacheDS
> 2.0? In Studio I created some object classes and attribute types and
> stored them in a subtree of ou=schema. So the ldif files are present in
> their correct destinations. In Studio I can also build entries with
> them. But in my application I get the following error: ERR_04269
> ATTRIBUTE_TYPE for OID [any of my schema objects] does not exist!
>
> The problem must be with my own schema because when I move my schema
> objects into any of the predefined schema, I can use them.
>
> Here's what I tried so far:
>
> connection.loadSchema();
> schemaManager = connection.getSchemaManager();
>
> SchemaLoader loader = schemaManager.getLoader();
> loader.addSchema(new DefaultSchema("mySchema")); //?
>
> schemaManager.enable("mySchema"); //?
> schemaManager.load("mySchema"); //?
>
> Well, after this my schema is enabled and loaded but the elements are
> still not registered. So how can I register them?
>
> Thank you,
> kind regards,
> Christoph



-- 
Kiran Ayyagari

Mime
View raw message