directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fourat ZOUARI <fou...@gmail.com>
Subject Re: Problem creating a new object class
Date Tue, 08 Nov 2011 12:59:27 GMT
Hi,

Am working with the AD studio 1.5.3 which is connecting to a OpenLDAP 2.4.3
server, i've opened the Schema editor perspective and added the new
objectClass 'Tux' to the Object Classes subdirectory, now i can see it with
ther  other objects (top, person, posixAccount ...), when i switch back to
LDAP perspective, i see all other objectClasses but not my new one.

Thank you !


On Tue, Nov 8, 2011 at 1:51 PM, Pierre-Arnaud Marcelot <pa@marcelot.net>wrote:

> Hi Fourat,
>
> Is this related to ApacheDS (the server) or Apache Directory Studio, or
> both?
> Which versions?
>
> Could you be a little more descriptive about the steps you went through?
> "Saved it" is pretty vague...
> Where did you save it exactly?
>
> Thanks!
>
> Regards,
> Pierre-Arnaud
>
> On 8 nov. 2011, at 13:45, Fourat ZOUARI wrote:
>
> > Hi,
> >
> > I've created a new object class, here's it's source code:
> >
> > objectclass ( 1.3.6.1.4.1.76561.1
> >>
> >> NAME 'Tux'
> >>
> >> DESC 'Staff'
> >>
> >> SUP top
> >>
> >> STRUCTURAL
> >>
> >> MUST ( description $ displayName $ documentIdentifier $ documentTitle $
> >>> email $ employeeNumber $ homePhone $ homePostalAddress $ personalTitle
> $
> >>> serialNumber $ userPassword )
> >>
> >> MAY ( photo $ SipExtension $ Departement )
> >>
> >> )
> >>
> >>
> > Saved it, and still cannot see it as an option in objectClass attribute
> of
> > any entry ...
> >
> > Any idea ?
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message