directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fred Arters <fredart...@gmail.com>
Subject Re: Can't install 1.5.7 on mac osx after installing 2.0M1
Date Thu, 04 Aug 2011 15:04:31 GMT
That worked!   Thank you!

-Fred Arters




On Aug 4, 2011, at 2:36 PM, Pierre-Arnaud Marcelot wrote:

> On 4 août 2011, at 16:07, Fred Arters wrote:
> 
>> Hello,
> 
> Hi Fred,
> 
>> I've been using OpenDS for a while now and wanted to try something different, so
I was going to give apacheds a change.  Looking at the website I saw there was a 2.0 milestone
release and I downloaded and ran the installer for Mac OSX.
>> 
>> It seemed to install but then trying to figure out how to manage it I found that
the links for the documentation on the 2.0 website are broken.   I tried to use the prior
release (1.5.7) docs but they don't seem to match up (cant find server.xml in 2.0 for example).
> 
> Actually, the documentation for ApacheDS 2.0 is missing ATM. The 1.5.x documentation
needs to be duplicated and updated to match the modifications that were made for 2.0.
> 
> FYI, the server.xml file does not exist anymore. It has been replaced by a single 'config.ldif'
LDIF file (in the conf folder of the instance).
> 
>> I called it a failed attempt and tried to remove it and install 1.5.7.   I stopped
the service, deleted the plist file, the apacheds file in /usr/bin and the directory under
/usr/local  
>> 
>> Then I downloaded and ran the 1.5.7 installer.   That reports that it cannot install
because I have a newer version of the software installed on the drive.  
>> 
>> Anyone know what else I need to remove to get 1.5.7 to install?
> 
> If you're on Snow Leopard (should work the same on Lion too, but I haven't tested yet),
you need to remove the following installation receipts files:
>> $ sudo rm /private/var/db/receipts/org.apache.directory.server.bom
>> $ sudo rm /private/var/db/receipts/org.apache.directory.server.plist
> 
> Hope this helps,
> Pierre-Arnaud
> 
>> -Fred Arters
> 


Mime
View raw message