directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Seelmann <seelm...@apache.org>
Subject Re: Search result is empty when authenticating with user's DN
Date Tue, 12 Apr 2011 06:18:08 GMT
Hi Mat,

I assume you are using Apache Directory Studio 1.5.3 which is bundled
with an embedded ApacheDS 1.5.6.

It sounds that you enabled access control in server.xml or in the
configuration editor. If so then you need setup the ACI subsystem, [1]
contains a nice example.

Kind Regards
Stefan


[1] http://directory.apache.org/apacheds/1.5/32-basic-authorization.html



On Tue, Apr 12, 2011 at 3:16 AM, Mat Gessel <mat.gessel@gmail.com> wrote:
> Do I need to do something special to allow a given user to search the directory?
>
> I'm using Directory Studio with the embedded server. Search returns 1
> entry when I bind with the built-in admin (uid=admin,ou=system).
> Search returns 0 entries when I bind (successfully) with the DN of
> another user. The user and search base are contained by a custom
> partition.
>
> Succeeds:
>> ldapsearch -H ldap://localhost:10389 -x -D "uid=admin,ou=system" -w secret -b "ou=people,o=example"
-s one "(uid=jdoe)"
>
> Fails:
>> ldapsearch -H ldap://localhost:10389 -x -D "exampleid=20003,ou=people,o=example"
-w secret -b "ou=people,o=example" -s one "(uid=jdoe)"
>
> I experience a similar problem if I create a connection in Directory
> Studio using the user's DN. The result is an empty DIT in the LDAP
> Browser.
>
> --
> Mat Gessel
> http://www.asquare.net
>

Mime
View raw message