directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Styssi Slater <>
Subject Re: Can't Start ApachedDS 1.5.7 on Ubuntu 8.04 64bit
Date Fri, 07 Jan 2011 20:38:06 GMT
This is the stacktrace I get when I try to connect to the apacheds server

 - Connection refused: connect (<IP_OF_SERVER_HIDDEN>:389)
  javax.naming.CommunicationException: <IP_OF_SERVER_HIDDEN>:389 [Root exception 
is Connection refused: connect]
    at com.sun.jndi.ldap.Connection.<init>(Unknown Source)
    at com.sun.jndi.ldap.LdapClient.<init>(Unknown Source)
    at com.sun.jndi.ldap.LdapClient.getInstance(Unknown Source)
    at com.sun.jndi.ldap.LdapCtx.connect(Unknown Source)
    at com.sun.jndi.ldap.LdapCtx.<init>(Unknown Source)
    at com.sun.jndi.ldap.LdapCtxFactory.getUsingURL(Unknown Source)
    at com.sun.jndi.ldap.LdapCtxFactory.getUsingURLs(Unknown Source)
    at com.sun.jndi.ldap.LdapCtxFactory.getLdapCtxInstance(Unknown Source)
    at com.sun.jndi.ldap.LdapCtxFactory.getInitialContext(Unknown Source)
    at javax.naming.spi.NamingManager.getInitialContext(Unknown Source)
    at javax.naming.InitialContext.getDefaultInitCtx(Unknown Source)
    at javax.naming.InitialContext.init(Unknown Source)
    at javax.naming.ldap.InitialLdapContext.<init>(Unknown Source)







Caused by: Connection refused: connect
    at Method)
    at Source)
    at Source)
    at Source)
    at Source)
    at Source)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.sun.jndi.ldap.Connection.createSocket(Unknown Source)
    ... 20 more

From: Styssi Slater <>
Sent: Fri, January 7, 2011 9:29:46 PM
Subject: Re: Can't Start ApachedDS 1.5.7 on Ubuntu 8.04 64bit

Yes that was a typo.

I first uninstalled the 64 bit version by deleting the following files and 

Is there sth. else I have to do for deinstallation? Is there an easier way to do 


Then I installed the 32 bit version in the same way I installed the 64bit 

Starting the server does not throw an error message.

I have problems to make a connection to the ldap server from my client. Now I 
don't know if this is because of the 32bit version or because I enter the wrong 
parameters. I set the client to port 389 and also tried port 10389 and I set the 

client to no_encryption. Are these the basic values after installation?

Thanks for your help so far. Looks like we solved the first problem. Since the 
server at least starts now.

From: Emmanuel Lecharny <>
Sent: Fri, January 7, 2011 8:04:32 PM
Subject: Re: Can't Start ApachedDS 1.5.7 on Ubuntu 8.04 64bit

On 1/7/11 4:05 PM, Tobias Huber wrote:
> Hi,
> I just installed the apacheDS 1.5.7 the following way
> 1. Download apacheds.bin for 64 bit Linux system
> 2. Changed the permissions of the file as follows.
> chmod u+x apacheds-1.5.7-x86_64.bin
> 3. Change to root and run the installer as follows.
> ./apacheds-1.5.5-x86_64.bin

Is that a typo ??? (I guess so).

Can you also try installing the 32 bits version ?

Emmanuel L├ęcharny

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message