directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mcto...@gmail.com
Subject Re: [ApacheDS] Cannot enable custom schema such as mozilla schema
Date Wed, 15 Sep 2010 14:00:14 GMT
  Thanks, but schema mozilla only has dependencies on core and system, 
neither of which have that attribute.


On 15/09/10 11:55 PM, Kiran Ayyagari wrote:
> On Wed, Sep 15, 2010 at 7:15 PM,<mctozzy@gmail.com>  wrote:
>> Continuing my journey with ApacheDS 1.5.7 and Thunderbird. Is working fine
>> for the basic LDAP attributes. On the back of this, I'm now trying to enable
>> the mozilla schema, but not having much luck. I have changed the m-disabled
>> attribute to FALSE, but no matter what I do, I cannot get its object class
>> mozillaAbPersonObsolete to appear in the list of classes in the schema
>> browser or the entry editors.  (Why is it labelled obsolete by the way?)
>>
>> I have disconnected/reconnected Studio, refreshed, restarted service etc to
>> no avail.
> hmm, can you try reloading the schema and see
>> Same problem seems to affect some of the other optional schemas. The ones
>> that seem problematic have the attribute m-disabled present, almost as if
>> "TRUE" and "FALSE" are being treated as true. The schemas that don't have
>> this attribute at all appear fine.
> check for the m-disabled attribute in the dependent schemas also and
> change them to
> FALSE if set to TRUE
>
> hth
> Kiran Ayyagari

Mime
View raw message