directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jfmel...@free.fr
Subject Re: [ApacheDS] Embedded 1.5.7 server how to enable ACI at startup
Date Wed, 22 Sep 2010 08:29:03 GMT
Hi

Have I a way to enable cache at startup ?

Regards
Jean-François Melian

----- "Emmanuel Lecharny" <elecharny@gmail.com> a écrit :

| On 9/21/10 4:33 PM, jfmelian@free.fr wrote:
| > Hi
| >
| > I have an embedded server in 1.5.5 version.
| > I want to migrate in 1.5.7.
| >
| > The server work work from scratch :
| > - ldif schema
| > - system partition
| > - my partition
| > - enable Access Control and set ACI
| > - load ldif file
| > - with studio I can see all the entries with apacheds admin user and
| with another custom admin user .
| >
| > Then I stop and restart my server :
| > - with apache ds admin user I can see all entries and I can see also
| the subentries for aci : ok
| > - but with the custom admin user I can't see any entries (I see only
| rootDSE)
| >
| > Then with studio and apacheds admin user I load ACI in the ACI
| editor and click ok to reload then.
| > Then I can see all entries with custom admin user.
| >
| > How to enable ACI at startup ?
| > I already set the flag :
| directoryService.setAccessControlEnabled(true);
| >
| > Thanks for help
| This is a bug we are working on atm : the ACI are not realoaded at
| start 
| up. It's because the cache is not initialized...
| 
| -- 
| Regards,
| Cordialement,
| Emmanuel Lécharny
| www.iktek.com

Mime
View raw message