directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Les Hazlewood <...@katasoft.com>
Subject Re: First time Apache Directory user - can't see custom partition?
Date Tue, 20 Jul 2010 22:03:57 GMT
Hi Emmanuel,

Thanks so much for clarifying!

For posterity, for anyone else doing this through Studio, I added it
by doing the following:

- Right-clicking the 'Root DSE' node --> New --> New Context Entry.
- I then chose 'Create entry from scratch'
- I then added Object Classes 'dcObject' and 'organization' (which
automatically include 'top') and clicked 'Next'
- DN Context Entry: dc=example,dc=com and clicked 'Next'
- Double-clicked the 'o' (organization) value column, and entered the
value 'Example, Inc.'
- clicked Finish

Also, great work on Directory Studio!

Best,

-- 
Les Hazlewood
CTO, Katasoft, Inc.
http://www.katasoft.com

On Tue, Jul 20, 2010 at 2:28 PM, Emmanuel Lecharny <elecharny@gmail.com> wrote:
>  On 7/20/10 11:15 PM, Les Hazlewood wrote:
>>
>> Hi all,
>
> Hi, Les,
>>
>> I just installed Apache Directory Studio 1.5.7, and created a new
>> Apache Directory Server instance.  Before starting the server
>> instance, I edited it's configuration in the Studio UI and added a
>> custom partition (dc=test,dc=com).
>>
>> I started the server, created a connection, and opened the DIT in the
>> LDAP Browser panel on the left side of ADS.  This is what I see:
>
> yes, the context entry is not anymore created automatically. You have to add
> it by hand. This is easy to do in studio, by right-clicking on the root and
> select 'add context entry', then create an entry using the domain OC and the
> required Attributes.
>
>> DIT
>> ----Root DSE (3)
>> --------ou=schema (19)
>> --------ou=system(5)
>>
>> However, my view does not match the documentation here:
>>
>>
>> http://directory.apache.org/apacheds/1.5/143-adding-your-own-partition-resp-suffix.html
>>
>> The documentation shows a globe icon next to the dc=example,dc=com
>> partition.  But in my fresh install, I don't see that icon for the
>> 'example' partition or my new 'test' partition.
>>
>> Why aren't the example and test partitions displaying like shown in
>> the documentation?  Did I do something wrong?
>
> No, the doco is out of date :/
>
>
> --
> Regards,
> Cordialement,
> Emmanuel Lécharny
> www.iktek.com

Mime
View raw message