directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pierre-Arnaud Marcelot ...@marcelot.net>
Subject Re: ApacheDS: Install on Solaris
Date Tue, 22 Jun 2010 17:25:10 GMT
Hi Nick,

By default, the server will run on ports 10389 (LDAP) and 10636 (LDAPS).

What kind of installer did you use to install Apache DS ? The dedicated Solaris one ?

Did you test the connection before moving files around and modifying the startup script ?

FYI, we also deliver Apache DS as a binary installer and an archive.
Maybe you could also try these distributions to see if you get the same results.

Regards,
Pierre-Arnaud


On 22 juin 2010, at 15:54, Nicholas Syrotiuk wrote:

> Hello,
> 
> No, nothing is running on these ports.  And there is no process on the machine associated
with apacheds.
> 
> Output from: $ ./apacheds-default status
> Apache Directory Server - default is not running.
> 
> ------------------------
> 
> The machine has several other services running on it, with various IP addresses.
> 
> I want the ApacheDS service to run using IP address 130.88.26.153 however I have changed
none of the default settings for now.  What happens when ApacheDS is first installed?  I mean,
what address/port will it try to use?
> 
> Regards, Nick
> 
> 
> Pierre-Arnaud Marcelot wrote:
>> Hi,
>> Actually these should be "false errors" and the server should actually be running
fine.
>> These error logs have been fixed in the current trunk if I recall correctly.
>> Can you verify if the server is running on both ports ?
>> Thanks,
>> Pierre-Arnaud
>> On 22 juin 2010, at 10:41, Nicholas Syrotiuk wrote:
>>> Hello,
>>> 
>>> We are trying to install ApacheDS 1.5.7 on:
>>> SunOS shibora 5.10 Generic_142900-11 sun4v sparc SUNW,T5440
>>> 
>>> Our Java version is:
>>> java version "1.5.0_22"
>>> Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_22-b03)
>>> Java HotSpot(TM) Server VM (build 1.5.0_22-b03, mixed mode)
>>> 
>>> The JAVA_HOME variable is set to /usr/java/jre .
>>> 
>>> We have put the ApacheDS files in:
>>> /shibidp/ldap/
>>> 
>>> We would like to run the server using an account called "shibidp" and have modified
the start up script accordingly.
>>> 
>>> However, when we start the server, the apacheds-rolling.log contains:
>>> 
>>> [15:58:27] ERROR [org.apache.directory.shared.ldap.entry.DefaultServerAttribute]
- ERR_04450 The value {0} is incorrect, it hasnt been added
>>> [15:58:27] ERROR [org.apache.directory.server.Service] - Cannot start the server
: reuseAddress can't be set while the acceptor is bound.
>>> 
>>> As far as I can tell, ports 10389 and 10636 are not in use by other services
running on the machine.
>>> 
>>> What do you suppose is wrong with our installation?
>>> 
>>> Cheers, Nick
>>> -- 
>>> N Syrotiuk | Mimas | University of Manchester | Manchester  M13 9PL
> 
> -- 
> N Syrotiuk | Mimas | University of Manchester | Manchester  M13 9PL


Mime
View raw message