directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Lecharny <elecha...@gmail.com>
Subject Re: Upgrading to Apache 1.5.7
Date Thu, 17 Jun 2010 06:39:26 GMT
On 6/16/10 11:09 AM, Sudheer Kumar wrote:
> Hi
>
> We are upgrading to Apache 1.5.7 from Apache 1.5.4.  We have some approval
> issues for certain packages they are:
> 1. bouncy castle : bcprov-jdk15-140.jar
>
>                 Is it okay to use bouncy castle 1.34 instead of 140?  We have
> approval for bcprov-jdk15-134 but not for bcprov-jdk15-140.jar.
>    
AFAICR, there is a issue with 1.34 version with some patented encryption 
algorithm, so we switched to 140. I think you can safely use 1.34,/
>                I replaced it with bcprov-jdk15-134 and changed the code
> (javax.security.auth.x500.X500Principal.TlsKeyGenerator.java) :-
>                     certGen.generate( privateKey, "BC" )
> to certGen.generateX509Certificate( privateKey, "BC" );
>               Hope this is ok?  Could you please let me know how to test
> this? I mean a test case to test this feature?
>    

I have no idea. Here, you are on your own.
>
> 2. Jetty: jetty-6.1.14.jar and jetty-util-6.1.14.jar.
>           I just removed these jars and commented the
> org.apache.directory.server.Service.initHttpServer() and removed the
> server.integration package.  I hope this will not impact Apache DS as any
> way Jetty server is not invoked by default and we have no plan to configure
> http setting in server.xml.
>    
That's OK. You don't have yo use Jetty if you don't need to, and we are 
not doing anything special with Jetty atm. It was just addedfor future 
usage.


-- 
Regards,
Cordialement,
Emmanuel L├ęcharny
www.nextury.com



Mime
View raw message