directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wright, Zane" <Zane_Wri...@sra.com>
Subject According to the schema attribute administrativeRole is not allowed!
Date Tue, 18 May 2010 13:05:15 GMT
Hello all,

 

I have been trying to go through the Apache Directory tutorials to get
myself up to speed on their implementation of LDAP but I came across a
problem. When going through the basic authorization tutorial for 1.5,
specifically the "Simple example for the ACI subsystem" I tried to add
the attribute administrativeRole but got the error: "Warning! According
to the schema attribute administrativeRole is not allowed!" I have
enabled the accessControlEnabled option and restarted the service, and
have tried to continue through this problem and finish the tutorial but
every step along the way I would get the same error for
subtreeSpecification, and prescriptiveACI additions.

 

Suffice it to say that when I run through the 'testing' part of the demo
I can connect and query but when I run the query with my new full
permissions user I get no results and continue to get no results until I
log in with the system admin account. Can anybody help me with this
problem? I'm sure it's something easy but I cannot find any reference to
this specific error anywhere other than inside the source. As a note,
I'm running the latest version of Apache Directory Server with Server
2008 64 bit and the latest JDK 1.5 release. Thanks,

 

Zane Wright

 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message