directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Seelmann <seelm...@apache.org>
Subject Re: Problem using custom scheme with Apache Directory Studio
Date Mon, 26 Apr 2010 07:52:05 GMT
Hi Frederik,

Weishäupl.Frederik schrieb:
> Hi,
> 
> I've a question regarding adding my own custom schema "Kunde" in Apache Directory 1.5.6.
I created a custom objectclass 'Kunden' with a custom attribute 'customerId':
> 
> Objectclass 'Kunden':
> objectclass ( 1.2.3.4.5.6.7.8.1 
> 	NAME 'kunden' 
> 	STRUCTURAL 
> 	MAY customerId 
>  )
> 
> Attributetype 'customerId':
> attributetype ( 1.2.3.4.5.6.7.8.0 
> 	NAME 'customerId' 
> 	EQUALITY caseIgnoreMatch 
> 	SUBSTR caseIgnoreSubstringsMatch 
> 	SYNTAX 1.3.6.1.4.1.1466.115.121.1.15 
> 	SINGLE-VALUE 
>  )
> 
> I imported the new schema to Apache Directory successfully. In Apache Directory Studio
I can see my new scheme under ou=schema,cn=kunde.
> 
> Unfortunately I'm not able to select my new objectclass when I try to add a new LDAP
Entry with Apache Directory Studio. Even in the scheme browser I can't find it.
> 
> Any suggestions? Thx a lot in advance.

Please try to reload the schema from the server:
- press the reload button in the schema browser [1] or
- press the reload button in the object class selection of the new entry
wizard [2]

Also make sure that your schema isn't disabled (no m-disabled:TRUE in
cn=kunde,ou=schema).

Hope that helps,
Stefan

[1]http://directory.apache.org/studio/static/users_guide/ldap_browser/images/tools_schema_browser_1.png
[2]http://directory.apache.org/studio/static/users_guide/ldap_browser/images/tools_newentry_wizard_2.png

Mime
View raw message