directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cheong Chung Onn <chung...@greenfossil.com>
Subject Re: My Embedded Server broken for ApacheDS 1.5.7
Date Sun, 18 Apr 2010 11:00:54 GMT
Cheong Chung Onn wrote, On 4/18/10 1:16 PM:
> Hi,
>
> Earlier, I was planning to upgrade my embedded server from 1.5.5 to 
> 1.5.6 and I learned that 1.5.7 has just been released very recently. 
> Naturally, I chose to skip 1.5.6 and moved on to 1.5.7, however as I 
> upgrade my embedded server I realized there are changes in 1.5.7 that 
> is not backward compatible namely changes to  - LdapDN, Index, 
> ServerEntry and Partition#init() is removed.
>
> I tried to checkout project ApacheDS-core from Tags 1.5.7 for examples 
> but failed to find any relevant test case examples. Would someone help 
> to direct me to the right maven sub project to where I can find sample 
> testcases so that I  can fix my embedded server again.
>
> Thanks in advance.
>
>
Hi again,

I tried adapting the code found in example EmbeddedADS.java by replacing 
LdapDN with DN class and LdapNameNotFoundException (removed in version 
1.5.7) with Exception class. I received an NPE when 
DirectoryService#service method is invoked. Below is the stack trace.

Any help will be appreciated. Thanks in advance

14299 [main] INFO 
org.apache.directory.server.core.DefaultDirectoryService - ApacheDS 
shutdown hook has been registered with the runtime.
Exception in thread "main" java.lang.NullPointerException
     at 
org.apache.directory.server.core.schema.DefaultSchemaService.initialize(DefaultSchemaService.java:381)
     at 
org.apache.directory.server.core.DefaultDirectoryService.initialize(DefaultDirectoryService.java:1425)
     at 
org.apache.directory.server.core.DefaultDirectoryService.startup(DefaultDirectoryService.java:907)
     at com.greenfossil.test.util.EmbeddedADS.init(EmbeddedADS.java:108)
     at com.greenfossil.test.util.EmbeddedADS.<init>(EmbeddedADS.java:159)
     at 
com.greenfossil.test.util.TestLdapService.main(TestLdapService.java:21)



Mime
View raw message