directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Horne <>
Subject Re: Standalone & Webapp Examples not working with 1.5.6
Date Fri, 26 Mar 2010 03:00:04 GMT
Thanks for the replies and I'll look forward to the updates.  One place where you may want
to start is with installer/apacheds-noarch.  As I was trying to work out what was wrong with
my code, I thought I'd get it (installer/apacheds-noarch) going and then make some exploratory
changes.  It worked fine after a maven build and running the script.  However
when I removed arg[0] from the script (target/plan/server.xml) to make it use the defaults,
it crashed with the same exception that my code had... 

Exception in thread "main" java.lang.NullPointerException 

My understanding is that it should use the defaults with no-args... so that may give you a
place to start.  Let me know if you want me to test anything.


On 26/03/2010, at 1:21 AM, Stefan Zoerner wrote:

> Peter Horne wrote:
>> I started using ApacheDS a few weeks ago and was using an embedded model like the
webapp demo (embedded + TCP).  Notwithstanding the renaming to DN etc, my program, and the
demos verbatim, no longer work with 1.5.6.  I am happy to do the work to describe specific
bug details, however it seemed to be such a big break I thought I'd ask the general question
as to whether there was any work being done to get the demos in the doco refreshed.  
> The main problems are that the documentation is not part of our build/CI, and that we
do not release the documentation with the software (no versioning of the documentation).
> I'll try to retest/update the examples this weekend.
> Thanks for the feedback, Peter.
> Greetings from Hamburg,
>    StefanZ

View raw message