directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pierre-Arnaud Marcelot ...@marcelot.net>
Subject Re: Mac OS X 10.6 Support?
Date Mon, 12 Oct 2009 11:25:10 GMT
Hi Tom,
I just gave it a try on both Leopard and Snow Leopard.

I'm getting these "errors" on both systems:

> INFO   | jvm 1    | 2009/10/12 12:07:32 | [12:07:32] WARN
> [org.apache.directory.server.schema.registries.DefaultOidRegistry] - OID for
> name 'krb5PrincipalName' was not found within the OID registry

INFO   | jvm 1    | 2009/10/12 12:07:33 | [12:07:33] ERROR
> [org.apache.directory.server.schema.registries.DefaultAttributeTypeRegistry]
> - attributeType w/ OID 2.5.4.16 not registered!

INFO   | jvm 1    | 2009/10/12 12:07:34 | [12:07:34] ERROR
> [org.apache.directory.server.Service] - Cannot start the server :
> reuseAddress can't be set while the acceptor is bound.


But... It doesn't actually stop the server. It is perfectly running on port
10389 for the LDAP protocol and port 10686 (while it should be 10636, as
usual... [1]) for the LDAPS protocol.

I also tested it on Ubuntu and I got the same "errors" too. So, I believe
it's a global bug that does not depend on the system and architecture.


However I noticed this warning from our Tanuki wrapper on Snow Leopard:

> INFO   | jvm 1    | 2009/10/12 12:07:27 | WARNING - Unable to load the
> Wrapper's native library 'libwrapper.jnilib'.

INFO   | jvm 1    | 2009/10/12 12:07:27 |           The file is located on
> the path at the following location but

INFO   | jvm 1    | 2009/10/12 12:07:27 |           could not be loaded:

INFO   | jvm 1    | 2009/10/12 12:07:27 |
> /usr/local/apacheds-1.5.5/bin/../lib/libwrapper.jnilib

INFO   | jvm 1    | 2009/10/12 12:07:27 |           Please verify that the
> file is readable by the current user

INFO   | jvm 1    | 2009/10/12 12:07:27 |           and that the file has
> not been corrupted in any way.

INFO   | jvm 1    | 2009/10/12 12:07:27 |           One common cause of this
> problem is running a 32-bit version

INFO   | jvm 1    | 2009/10/12 12:07:27 |           of the Wrapper with a
> 64-bit version of Java, or vica versa.

INFO   | jvm 1    | 2009/10/12 12:07:27 |           This is a 64-bit JVM.

INFO   | jvm 1    | 2009/10/12 12:07:27 |           Reported cause:

INFO   | jvm 1    | 2009/10/12 12:07:27 |
> /usr/local/apacheds-1.5.5/lib/libwrapper.jnilib:  no suitable image found.
>  Did find:  /usr/local/apacheds-1.5.5/lib/libwrapper.jnilib: no matching
> architecture in universal wrapper

INFO   | jvm 1    | 2009/10/12 12:07:27 |           System signals will not
> be handled correctly.


It looks like the wrapper did not like so much the 64-bit JVM of Snow
Leopard. I'll see on the Tanuki website if a newer version is available with
a proper version of the wrapper for 64-bit JVM on a Mac.


To answer your question on the 'server.xml' file, it isn't stored anymore in
the 'conf' folder at the root of the installation
('/usr/local/apacheds-1.5.5/'). As we're supporting multiple instances, each
instance has its own 'server.xml' file. Apache DS comes with a default
instance and its configuration file is located at
'/usr/local/apacheds-1.5.5/instances/default/conf/server.xml'.

Hope this helps,
Pierre-Arnaud

[1] - I already opened a Jira about that.
https://issues.apache.org/jira/browse/DIRSERVER-1410


On Sun, Oct 11, 2009 at 8:01 PM, Tom Jones <tjones@acworld.com> wrote:

> Thanks,
> OK, I'll see if Pierre responds. For more info this system is a 10.6.1 Mac
> OS X system with no services running. The ApacheDS install is the 1.5.5
> package. I never installed any other build before it.
>
> As for the server.xml, does this file get created once the service has
> successfully launched or should it be there as part of the install?
>
> Thanks,
> tom
>
>
>
> ----- Original Message -----
> From: "Alex Karasulu" <akarasulu@gmail.com>
> To: users@directory.apache.org
> Sent: Saturday, October 10, 2009 9:47:45 PM GMT -08:00 US/Canada Pacific
> Subject: Re: Mac OS X 10.6 Support?
>
> Hi Tom,
>
> On Sun, Oct 11, 2009 at 4:12 AM, Tom Jones <tjones@acworld.com> wrote:
>
> > Hello,
> > I have a need for a LDAP server in my project. I was going to use
> OpenLDAP
> > until I came across the ApacheDS project. I'm very excited about the
> > possibility with the studio integration etc.
> >
> > So, I downloaded the Mac OS X installer and installed it on my box, but
> I'm
> > unable to get it started. I was looking for the server.xml file but could
> > not find it.
> >
> > This is the error in the wrapper.log file, can someone please help me,
> >
> > Thanks,
> > tom
> >
> > STATUS | wrapper  | 2009/10/10 15:37:06 | Launching a JVM...
> > INFO   | jvm 1    | 2009/10/10 15:37:11 | Wrapper (Version 3.2.3)
> > http://wrapper.tanukisoftware.org
> > INFO   | jvm 1    | 2009/10/10 15:37:11 |   Copyright 1999-2006 Tanuki
> > Software, Inc.  All Rights Reserved.
> > INFO   | jvm 1    | 2009/10/10 15:37:11 |
> > INFO   | jvm 1    | 2009/10/10 15:37:11 |            _
> > _          ____  ____
> > INFO   | jvm 1    | 2009/10/10 15:37:11 |           / \   _ __    ___
>  ___|
> > |__   ___|  _ \/ ___|
> > INFO   | jvm 1    | 2009/10/10 15:37:11 |          / _ \ | '_ \ / _` |/
> __|
> > '_ \ / _ \ | | \___ \
> > INFO   | jvm 1    | 2009/10/10 15:37:11 |         / ___ \| |_) | (_| |
> (__|
> > | | |  __/ |_| |___) |
> > INFO   | jvm 1    | 2009/10/10 15:37:11 |        /_/   \_\ .__/
> > \__,_|\___|_| |_|\___|____/|____/
> > INFO   | jvm 1    | 2009/10/10 15:37:11 |                |_|
> > INFO   | jvm 1    | 2009/10/10 15:37:11 |
> > INFO   | jvm 1    | 2009/10/10 15:37:15 | [15:37:15] WARN
> > [org.apache.directory.server.schema.registries.DefaultOidRegistry] - OID
> for
> > name 'krb5PrincipalName' was not found within the OID registry
> > INFO   | jvm 1    | 2009/10/10 15:37:15 | [15:37:15] ERROR
> >
> [org.apache.directory.server.schema.registries.DefaultAttributeTypeRegistry]
> > - attributeType w/ OID 2.5.4.16 not registered!
> > INFO   | jvm 1    | 2009/10/10 15:37:17 | [15:37:17] ERROR
> > [org.apache.directory.server.Service] - Cannot start the server :
> > reuseAddress can't be set while the acceptor is bound.
> >
>
> ApacheDS is trying to bind to some port which is already in use however
> this
> error message is not very clear on which port exactly is the culprit.  I
> imagine this is a stock ApacheDS installation WITHOUT other services such
> as
> Kerberos activated.  If this is the case it must be the LDAP port, which
> makes me think that you might have already started this instance of
> ApacheDS
> before or another older installation is still running.
>
> Pierre is our OSX guru.  He might have some more input for you on this
> matter.  I'm not very savvy on how our installers work (whether the clean
> out older installations) on Mac OSX.
>
> Regards,
> --
> Alex Karasulu
> My Blog :: http://www.jroller.com/akarasulu/
> Apache Directory Server :: http://directory.apache.org
> Apache MINA :: http://mina.apache.org
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message