directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Lecharny <elecha...@apache.org>
Subject Re: Null Pointer Exception while adding object class to schema
Date Mon, 28 Sep 2009 11:28:09 GMT
sumit goyal wrote:
> Hi Emmanuel,
>
> Thanks for your reply. I will check about the concurrent access part of our
> usage.
>
> Also, I have seen a couple of times that these kind of exceptions are thrown
> while starting the server (again with 1.5.4 server):
>
> Exception in thread "main" java.lang.NullPointerException
> at
> org.apache.directory.server.core.entry.ClonedServerEntry.<init>(ClonedServerEntry.java:67)
> at
> org.apache.directory.server.core.partition.impl.btree.jdbm.JdbmPartition.lookup(JdbmPartition.java:457)
> at
> org.apache.directory.server.core.partition.impl.btree.ServerEntryCursorAdaptor.get(ServerEntryCursorAdaptor.java:140)
> at
> org.apache.directory.server.core.partition.impl.btree.ServerEntryCursorAdaptor.get(ServerEntryCursorAdaptor.java:40)
> at
> org.apache.directory.server.core.filtering.BaseEntryFilteringCursor.next(BaseEntryFilteringCursor.java:502)
> at
> org.apache.directory.server.core.schema.SchemaPartitionDao.getSchemas(SchemaPartitionDao.java:170)
> at
> org.apache.directory.server.core.DefaultDirectoryService.initialize(DefaultDirectoryService.java:1331)
> at
> org.apache.directory.server.core.DefaultDirectoryService.startup(DefaultDirectoryService.java:840)
> at
> org.apache.directory.server.configuration.ApacheDS.startup(ApacheDS.java:126)
> at org.apache.directory.server.Service.init(Service.java:86)
> at org.apache.directory.server.UberjarMain.main(UberjarMain.java:56)
>
> I suppose this happened because the partition is not there or there is some
> mis-configuration with it. Can you pls confirm it?
>   
Most probably... Difficult for me to check the 1.5.4 code base here, as 
this part has been completely rewritten in the branch I'm working on 
currently, but in any case, a NPE is not good :/

My personnal guess is that some referenced schema is not anymore present 
in the schemaPartition, while trying to access it.

I don't think it's related to the configuration at this point, but much 
more with the operations done on the schema (addition/removal)

-- 
--
cordialement, regards,
Emmanuel L├ęcharny
www.iktek.com
directory.apache.org



Mime
View raw message