directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Lecharny <>
Subject Re: error resolving commons-io
Date Sat, 13 Jun 2009 04:00:05 GMT
Craig Swing wrote:
> When I try to resolve with this dependency:
> <dependency org="" name="apacheds-core"
> rev="1.5.4" />
> I get the following error
> inconsistent module descriptor file found in '
> bad organisation: expected='org.apache.commons' found='commons-io';
> Looking at the org.apache.commons directory, the poms refer to the
> organization as commons-io, thus the error.
> Is there something I can do to work around this?
The problem is that commons-io is defined in two places in the maven 
repository (probably a mistake).

We have changed the dependency in trunk to point to commons-io instead 
of org.apache.commons-io.

Now, I guess that you are trying to build your application including 
Apacheds, and you use commons-io somewhere else in your dependencies.
> One solution to move the directory server files into a local repository and
> modify the dependency to use commons-io as the organization.  This seems
> more of a hack to me and I'd prefer to avoid doing this.
atm, I'm not sure you have another workaround. It will probably be 
solved in 1.5.5

cordialement, regards,
Emmanuel L├ęcharny

View raw message