directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Seelmann <seelm...@apache.org>
Subject Re: [ApacheDS] Bind problems
Date Fri, 12 Jun 2009 12:36:09 GMT
Stefan Reuter schrieb:
> Hi,
> 
> I am about to migrate from OpenLDAP to ApacheDS. I've imported a number
> of users from OpenLDAP into ApacheDS using an LDIF file.
> Verifying the userpassword in Studio works fine but binding does not. It
> results in the following error:
> 
> [13:00:28] INFO
> [org.apache.directory.server.core.authn.SimpleAuthenticator] - Password
> not correct for user 'cn=admin,o=basa'
> [13:00:28] INFO
> [org.apache.directory.server.core.authn.AuthenticationInterceptor] -
> Authenticator
> org.apache.directory.server.core.authn.SimpleAuthenticator@418a9fc8
> failed to authenticate: BindContext for DN 'cn=admin,o=basa',
> credentials < [removed]>
> [13:00:28] INFO
> [org.apache.directory.server.core.authn.AuthenticationInterceptor] -
> Cannot bind to the server

Which ApacheDS version are you using?

> The userpasswords are in {SSHA} format.
> After changing the userpassword through Studio to a new value binding
> works. Unfortunately that's not an option for the migration.
> 
> What could cause the passwords not to be accepted for binding while at
> the same time verifying them in Studio works?

What happens if you save the non-working password, set a new, and set
the old saved again (set it using the text value editor).

Could you give us an example of such an {SSHA} userpassword that isn't
working, including its clear text?

Kind Regards,
Stefan


Mime
View raw message