directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pierre-Arnaud Marcelot ...@marcelot.net>
Subject Re: [Studio] How to increase Java VM Heap Space on Mac OS X 10.5.6?
Date Fri, 17 Apr 2009 07:01:51 GMT
Hi Matthias,

On Fri, Apr 17, 2009 at 8:02 AM, Matthias Grundler <
matthias.grundler@googlemail.com> wrote:

> Hi Pierre-Arnaud,
>
> thanks for your very quick response!
>
> Unfortunately, this did not seem to solve my problem. I have now
> created the file where you suggested and put in the content from the
> FAQ, which probably should give at least 128 MB of heap space:
>
> > cat /Applications/Apache\ Directory\
> Studio.app/Contents/MacOS/ApacheDirectoryStudio.ini
> -vmargs
> -Xms128m
> -Xmx512m
> -XX:PermSize=128m
> -XX:MaxPermSize=128m
>
> > ls -al /Applications/Apache\ Directory\
> Studio.app/Contents/MacOS/ApacheDirectoryStudio*
> -rwxr-xr-x@ 1 matthias admin  68512  8 Apr 23:31 /Applications/Apache
> Directory Studio.app/Contents/MacOS/ApacheDirectoryStudio
> -rw-r--r--  1 matthias admin     70 17 Apr 07:51 /Applications/Apache
> Directory Studio.app/Contents/MacOS/ApacheDirectoryStudio.ini


The configuration seems pretty OK.
Can you provide the content of the "Configuration Details" window?
You can access this information using the "Apache Directory Studio > About
Apache Directory Studio" menu and then the "Configuration Details" button.


> However, I'm still stuck with 64 MB according to what's shown in the
> status line at the bottom of the main Studio window, and I still
> experience the same crashes, so there again seems to be no difference
> at all.


I don't see that status line you're talking about. Can you give me a hint
where it is? Thanks.


Do you have any other suggestions?
>

Let's try another thing and edit the /Applications/Apache Directory
Studio/Contents/Info.plist file.
Look for the following the text:
========================================================
<string>-showlocation</string>
<!-- WARNING:
If you try to add a single VM argument (-vmargs) here,
*all* vmargs specified in eclipse.ini will be ignored.
We recommend to add all arguments in eclipse.ini
 -->
========================================================
And insert your instructions using the  <string>XXXX</string> tags.

If it works that way, we'll edit the FAQs

Regards,
Pierre-Arnaud

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message