directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Seelmann <seelm...@apache.org>
Subject Re: Samba PDC w/ ApacheDS LDAP Backend
Date Wed, 25 Feb 2009 18:55:47 GMT
Hi Nicola,

you need to enable the "samba" schema in ApacheDS. It is disabled by
default, just browse to the "cn=samba,ou=schema" entry and delete the
"m-disabled: TRUE" attribute.

See your prova.schema.ldif:
-------------------------
dn: cn=samba,ou=schema
objectClass: metaSchema
objectClass: top
cn: samba
m-dependencies: system
m-dependencies: core
m-dependencies: inetorgperson
m-dependencies: nis
m-disabled: TRUE         <--------- remove this ---------
-------------------------

Kind Regards,
Stefan


Nicola Tuveri schrieb:
> Hi,
> as you can guess from the object, I am trying to configure Samba to act as
> a Primary Domain Controller using LDAP as back-end and ApacheDS as LDAP
> Server.
> 
> Unfortunately I did not found any documentation regarding this particular
> setup, excepting few messages on mailing lists asserting the setup is
> possible; therefore I tried to adapt the equivalent configuration which
> uses OpenLDAP as LDAP server to fit my needs.
> 
> The problem is that, once configured the ApacheDS partition, the
> smbldap-tools and the samba server, I cannot populate the LDAP tree because
> it fails reporting some errors (log attached), from which I guess the LDAP
> does not recognize some OID of the samba schema.
> 
> This is the sequence of actions I have done until now:
> 
> * Installed ApacheD 1.5.4 on Centos 5.2
> * Duplicated the default instance for testing
> ** cp -a /var/lib/apacheds/default /var/lib/apacheds/prova
> ** mkdir -p /var/{log,run}/apacheds/prova
> ** chown -R apacheds:apacheds /var/{lib,log,run}/apacheds/prova 
> * Edited /var/lib/apacheds/prova/conf/server.xml with Apache Directory
> Studio (file in the attachment)
> * Started the "prova" istance (it contains only ou=system and ou=schema ,
> in the attachment as ldif export)
> ** /etc/init.d/apacheds start prova
> * Installed and configured smbldap-tools
> ** yum install -y smbldap-tools
> ** /etc/smbldap-tools/smbldap_bind.conf (in the attachment)
> ** /etc/smbldap-tools/smbldap.conf
> * Configured samba
> ** /etc/samba/smb.conf (in the attachment)
> * Attempt to populate the LDAP tree:
> ** smbldap-populate (failure log in the attachment)
> 
> The files in the attachment are exactly the same in use in the server.
> 
> Could you possibly give me some help or documentation reference?
> 
> 
> Thanks in advance,


Mime
View raw message