directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pierre-Arnaud Marcelot" ...@marcelot.net>
Subject Re: [ApacheDS] 1.5.3 install comments
Date Wed, 10 Sep 2008 12:03:24 GMT
Hi Andy,

On Wed, Sep 10, 2008 at 12:09 PM, Andy Jefferson <andy@datanucleus.org>wrote:

> Hi Pierre-Arnaud,
>
> >> I recently tried to upgrade to 1.5.3 (from 1.0.2). Some comments :-
> >> With 1.0.2 I installed using the "Basic Users Guide" from the docs, and
> >> since I was installing on Linux used
> >> the "apacheds-1.0.0-linux-i386-setup.jar". This worked fine.
> >> With 1.5.3 I thought I'd try the RPM. RPM installs fine. Sadly the "id"
> >> command isn't located for me. Would be nice if you'd check "/bin/id"
> since
> >> this is the location on Mandriva 200x.
>
> > I'm wondering what you mean by "isn't located". Does this mean that the
> post
> > installation shell script must not use 'id' but '/bin/id' ?
>
> Sorry I wasn't specific enough. I was wanting to start the server using
> /etc/rc.d/init.d/apacheds start default


Oh, ok.
I thought you were referring our post-installation script which also using
the 'id' command.
But as this script is using this command directly (without the full path,
i.e. "id"), I was wondering how this could be failing...

Thanks for this precision.


> [...]
>
> which indeed asks me to report the location of the "id" binary on my
> system :-) Simple hack of that file allows people using Mandriva Linux to
> use
> ApacheDS
>
> I raised
> http://issues.apache.org/jira/browse/DIRSERVER-1249


Thanks for this one and the other one (improvement on the 'default'
instance).

We'll try address these issues as soon as possible.

Thanks,
Pierre-Arnaud

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message