directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martynas Brijunas" <mbri...@gmail.com>
Subject Re: ApacheDS 1.2 underscore in attrib name problem
Date Wed, 27 Aug 2008 12:33:30 GMT
Hi guys,

thanks for your super fast replies! I have created a case DIRSTUDIO-378.

Best regards,
Martin

2008/8/27 Emmanuel Lecharny <elecharny@gmail.com>:
> Martynas Brijunas wrote:
>>
>> Hi,
>>
>> I came across a proble today and not sure if this is a feature, or a bug.
>>
>> I am using DS to connect to our Oracle OID server. Running a search,
>> getting the results I expect to get. The problem starts when I want to
>> select which attributes to display. If I want to display "user_id",
>>
>
> Underscores are not valid in an attributeType :
>
> attributetype = oid
> oid = descr / numericoid
> descr = keystring
> numericoid = number 1*( '.' number )
> keystring = leadkeychar *keychar
> leadkeychar = ALPHA
> keychar = ALPHA / DIGIT / '-'
> ALPHA   = %x41-5A / %x61-7A   ; "A"-"Z" / "a"-"z"
> DIGIT   = %x30 / LDIGIT       ; "0"-"9"
>
>
> (RFC 4512)
>
> I'm sorry that Oracle is not LDAP compliant...
>
> The only thing you can do is to fill a JIRA asking for an extension of
> Apache Studio in order to handle such corner cases. Not sure it can be done
> quickly, as we have many other things to do and we don't have an Oracle
> server to test such things.
>
> Thanks !
>
> --
> --
> cordialement, regards,
> Emmanuel L├ęcharny
> www.iktek.com
> directory.apache.org
>
>
>
Mime
View raw message