directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Seelmann <seelm...@apache.org>
Subject Re: [ApacheDS] Having trouble setting up access control
Date Mon, 28 Jul 2008 21:36:31 GMT
Hi guys,

I guess I know the problem.

administrativeRole is an operational attribute, however they are not
displayed by default. Please activate the 'Show operational attribute'
option in the entry editor preferences, see here:
http://directory.apache.org/studio/static/users_guide/ldap_browser/preferences_entry_editor.html

I just created a Jira, I'll implement this for the 1.2.0 final release:
https://issues.apache.org/jira/browse/DIRSTUDIO-361

Sorry for the inconvenience.

Kind regards,
Stefan


Dylan Taft schrieb:
> I'm having trouble with setting up access control in apacheDS.  I'm using
> Apache DS 1.5.3
> Apache Studio 1.2.0 RC1
> 
> I've tried to follow the docs listed here
> http://directory.apache.org/apacheds/1.5/32-basic-authorization.html
> 
> I've added accessControlEnabled in my server.xml file, restarted the services..
> 
> I've tried to add administrativeRole as an attribute to dc=example,dc=com in DS studio
> When I try, it just doesn't do it.  I get a little red X next to the object in the ldap
browser..no other errors.
> 
> Does anyone have a moment to walk me through doing this in studio?  I'm trying to have
everything marked as read only to normal users except the userPassword attribute.  I've tried
for several hours with no luck...
> 
> Thanks in advance!
> 
> 
>       


Mime
View raw message