directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emmanuel Lecharny" <elecha...@gmail.com>
Subject Re: ApacheDS 1.5
Date Sat, 14 Jun 2008 12:00:15 GMT
Hi Abdullah,

On Sat, Jun 14, 2008 at 7:42 AM, Abdullah Zahur <azahur@gmail.com> wrote:
> thanks,
> that worked... it seems like there were two Services installed
> 1) apacheds (default service)
> 2) apacheds (%INSTANCE%)
>
> uninstalling and then removing the rouge service and then reinstalling
> worked....
>
> 3 question now
> 1) Is their anyway I can run the apacheds 1.5.1 through command prompt
> the following command still gives the error that I mentioned in the original
> message
>
>>apacheds -c ../conf/apacheds.conf

There is a shell script named apacheds.sh (somewhere in apacheds,
don't remember exactly where it is). It uses maven, but it launches
the server from the command line.


>
> 2) Is there some documentation, so that if we download the latest source
> from "trunk-with-dependencies" that we can configure the server.xml to start
> the differenet services. I am more interested in starting the kerberos
> service, but its not very clear how to configure them in the xbean
> configuration... and well I dont know a lot about xbean stuff either

Not so simple... We really need to improve the documentation in this
area, that's for sure ...

>
> 3) is there a way to start the server directly from eclipse so that you can
> step through the code
> thanks

Yeah, sure : the entry point is the Main in UberMain.java class (in
apacheds/installers, AFAIR)



-- 
Regards,
Cordialement,
Emmanuel L├ęcharny
www.iktek.com

Mime
View raw message