directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Karasulu" <akaras...@apache.org>
Subject Re: Error 'attributeType w/ OID 1.3.6.1.1.1.1.15 not registered' when importing LDIF
Date Tue, 13 May 2008 07:17:00 GMT
You know when we detect that an OID is not registered we could ask the
schema partition to tell us which schema it is as well as all the other
information we need to let the user know.  You know how ubuntu tells you
when you try to run a command that is not installed?  Like you do svn and if
not installed it will tell you which package you need to install to have
that command, that's what we need here.

Alex

On Tue, May 13, 2008 at 2:50 AM, Emmanuel Lecharny <elecharny@apache.org>
wrote:

> Stefan Seelmann wrote:
>
> > Suriya Simsuwat wrote:
> >
> >
> > > Hi all,
> > >
> > > I got a problem when trying to import the new schema to Apacheds V.
> > > 1.5.2 with Studio V. 1.1.0.
> > >
> > > To import LDIF file consisting of custom schema to LDAP I did the
> > > following steps,
> > >
> > > 1. Open a new schema project. 2. Import the schema file in schema
> > > window to schema project by using the    option 'Import schemas from
> > > OpenLdap files'.
> > >      The schema content is defined as below.      objectclass (
> > > 1.0.0.5.2.1.3.8    NAME 'myListener'    DESC 'Listening Service'    SUP (top
> > > $ ipHost $ ipService)    STRUCTURAL    MUST ( cn $ host $ ipServicePort )
> > >  MAY ( ipHostNumber $ ipServiceProtocol )    )
> > >
> >
> > With step 2 you just imported the schema into Studio. You must export it
> > for ApacheDS, then import the created LDIF (it contains the schema
> > format for ApacheDS) using the LDAP Browser. Then you could continue
> > with step 3.
> >
> >
> >
> Stefan, there is another problem : the NIS schema is not enabled by
> default on the server, leading to the error
>
> attributeType w/ OID 1.3.6.1.1.1.1.15 not registered!]
>
> The NIS schema need to be enabled, which means the m-disabled flag for the
> cn=nis,cn=schema should be changed to 'FALSE'.
>
> In order to do that, launch Studio, connect to your server, select the
> cn=nis,ou=schema entry, and change the Disabled value to 'FALSE'.
>
> Then reimport your objectclass. It should work.
>
> --
> --
> cordialement, regards,
> Emmanuel L├ęcharny
> www.iktek.com
> directory.apache.org
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message