directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fu-Tung Cheng <futung.ch...@yahoo.com>
Subject Re: Advanced Users Guide
Date Fri, 04 Jan 2008 07:55:57 GMT
Hi Emmanuel,

That get's me a little farther, I've put the output below..  I was hoping to import the seven
seas example into apache ds running in the web application but I can't seem to get the data
into the directory.  I have played around with the standalone version and I tried taking the
standalone data and putting it into the apacheds war working directory but all that comes
up when I connect to the apacheds war is the system tree (no example tree and no seven seas
tree).  

Is there an easy way for me to get some sample data into the apacheds war?  

Thank for the reply and help !!!!

Fu-Tung


It is interesting as the servlet search returns what the example states:

*** ApacheDS RootDSE ***

supportedLDAPVersion: 3
objectClass: extensibleObject
objectClass: top
subschemaSubentry: cn=schema,ou=system
supportedFeatures: 1.3.6.1.4.1.4203.1.5.1
vendorName: Apache Software Foundation
supportedExtension: 1.3.6.1.4.1..1466.20036
namingContexts: ou=system
supportedControl: 2.16.840.1.113730.3.4.3
supportedControl: 2.16.840.1.113730.3.4.7
supportedControl: 1.3.6.1.4.1.4203.1.10.1
supportedControl: 2.16.840.1.113730.3.4.2
vendorVersion: 1.0.2

but the command line still doesn't return the expected result.

$ ldapsearch -x -h localhost -p 10389 -D "uid=admin,ou=system" -w secret \\ -b "" -s base
"(objectClass=*)" * +
# extended LDIF
#
# LDAPv3
# base <> with scope subtree
# filter: (objectclass=*)
# requesting: \ -b  -s base (objectClass=*) * +
#

# search result
search: 2
result: 32 No such object
text: failed on search operation: null:
    SearchRequest
        baseDn : ''

        filter : '(2.5.4.0=*) '
        scope : whole subtree
        types
 Only : false
no limit
        Time Limit : no limit
        Deref Aliases :
 never Deref Aliases
        attributes : 'base', '-s', '-b', '+', '(objectClass=*)', '*', '\'
:
org.apache.directory.shared.ldap.exception..LdapNameNotFo undException
        at org.apache.directory.server.core.partition.DefaultPartitionNexus.search(DefaultPartitionNexus.java:859)
...


----- Original Message ----
From: Emmanuel Lecharny <elecharny@gmail.com>
To: users@directory.apache.org
Sent: Thursday, January 3, 2008 11:39:18 PM
Subject: Re: Advanced Users Guide

>
> $ ldapsearch -h localhost -p 10389 -D "uid=admin,ou=system" -w secret
 \\ -b "" -s base "(objectClass=*)" * +
>   
Can you try with a -x added in the command line ? The ldapsearch tool 
default to SASL when this option is not set. :
 "-x     Use simple authentication instead of SASL."


-- 
--
cordialement, regards,
Emmanuel L├ęcharny
www.iktek.com
directory.apache.org








      ____________________________________________________________________________________
Looking for last minute shopping deals?  
Find them fast with Yahoo! Search.  http://tools.search.yahoo.com/newsearch/category.php?category=shopping
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message