directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pierre-Arnaud Marcelot" ...@marcelot.net>
Subject Re: Howto augment PROGRAMMATICALLY default Schema in APacheDS 1.5.0 ?
Date Wed, 19 Dec 2007 13:55:14 GMT
Hi Sylvain,

You can start Apache DS NoArch by launching the script 'apacheds.sh' or '
apacheds.bat', depending on your OS.

Hope this helps,
Pierre-Arnaud Marcelot


On 12/19/07, Sylvain RICHET <srichet@bee-ware.net> wrote:
>
> Emmanuel Lecharny a écrit :
> > Hi,
> >
> > I have tested the code against the trunk (which will become 1.5.2) and
> > it works well. Have you tried the samples against the 1.5.1 version,
> > which fixed a hell lot of problems ?
> >
> > Sylvain RICHET wrote:
> >> Emmanuel Lecharny a écrit :
> >>> Hi Sylvain,
> >>>
> >>> sorry for the delay. We will check the site to see if there is any
> >>> kind of problem in the documentation, and will keep you informed asap.
> >>>
> >>> Thanks for using ADS !
> >>>
> >>>
> >>>
> >>> On Dec 13, 2007 3:06 PM, Sylvain RICHET <srichet@bee-ware.net> wrote:
> >>>
> >>>> Hi,
> >>>>
> >>>> I want to augment the default schema of ApacheDS 1.5.0. in a unit
> test
> >>>> (extending org.apache.directory.server.unit.AbstractServerTest)
> >>>>
> >>>> This should be easy... but it's not
> >>>>
> >>>> The tip given here fails :
> >>>>
> http://directory.apache.org/apacheds/1.5/add-your-first-elements-to-the-schema.html#Addyourfirstelementstotheschema-UsingJNDItoaddtheschemaelementsprogrammatically
> >>>>
> >>>>
> >>>> The thrown error is :
> >>>> java.lang.UnsupportedOperationException
> >>>>     at
> >>>> org.apache.directory.server.core.jndi.ServerDirContext.getSchema(
> ServerDirContext.java:432)
> >>>>
> >>>>     ...
> >>>>
> >>>>
> >>>> Here, someone noticed the... bug (?) :
> >>>>
> http://www.nabble.com/-ldapserver--schema--How-to-programmatically-extract-schema-information-from-a-server-context-to13524142.html
> >>>>
> >>>>
> >>>>
> >>>> I didn't find any workaround yet...
> >>>>
> >>>>
> >>>> Thanks in advance
> >>>>
> >>>>
> >>>
> >>>
> >>>
> >>>
> >>
> >> Ok, Emmanuel
> >>
> >> Thanks for your response.
> >>
> >> I wait for new Apache DS updated docs for Christmas !
> >> ;-)
> >>
> >>
> >
> >
> Yep !
>
> I have donwloaded a tarball file "apacheds-noarch-1.5.1.tar.gz"
> (url :
> http://www.apache.org/dyn/closer.cgi/directory/apacheds/unstable/1.5/1.5.1
> )
>
> Then, untaring it gives a jar file, in ./apacheds-noarch/target directory
> :
> "apacheds-noarch-installer-1.5.1-app.jar"
>
> But, launching :
> java -jar ./apacheds-noarch/target/apacheds-noarch-installer-1.5.1-app.jar
>           _                     _          ____  ____
>          / \   _ __   __ _  ___| |__   ___|  _ \/ ___|
>         / _ \ | '_ \ / _` |/ __| '_ \ / _ \ | | \___ \
>        / ___ \| |_) | (_| | (__| | | |  __/ |_| |___) |
>       /_/   \_\ .__/ \__,_|\___|_| |_|\___|____/|____/
>
> |_|
>
> Exception in thread "main" java.lang.NullPointerException
>        at org.apache.directory.server.Service.init(Service.java:73)
>        at org.apache.directory.server.UberjarMain.main(UberjarMain.java
> :59)
>
>
>
> So, i can't get the ApacheDS 1.5.1 libraries (which should be in a ./lib
> sub-directory) !!
> That's the reason why i couldn't test schemas under ApacheDS 1.5.1...
>
> Any workaround ?
> Thanks in advance
>
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message