directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pierre-Arnaud Marcelot" ...@marcelot.net>
Subject Re: Error when open configuration file
Date Wed, 28 Nov 2007 10:25:08 GMT
Hi,

Thanks for reporting this.

I think this issue is related to an issue I figured out some time ago.

We are using Dom4J to parse the file and it seems the parser tries to load
the XSD definition contained in the file:
<!DOCTYPE beans PUBLIC "-//SPRING//DTD BEAN//EN"
  "http://www.springframework.org/dtd/spring-beans.dtd">

Unfortunately, if you're not connected to Internet, Dom4J won't be able to
load this XSD and the parsing will fail.

I tried to suppress this XSD checking thing in the configuration of the
parser but I could not find the right way to do it in the documentation or
Javadoc.

Anyone knows how to turn this off?

Thanks.
Pierre-Arnaud Marcelot


On Nov 28, 2007 8:58 AM, zhangzhongliang <zhangzhongl@neusoft.com> wrote:

> Hi,
> I installed the "apacheds-1.0.2-win32-setup" and
> "Apache_Directory_Studio_1.0.1_Windows" to learn more about LDAP knowledge
> and JNDI techs.I installed them by default.After Installation,I started
> the
> Apache Directory Studio tool,and double click the Example in the
> Connections
> view,and then the DIT appears at the LDAP Browser view.
> I followed the "ApacheDS v1.0 Basic User's Guide" and want to view the
> configuration file of ApacheDS example instance,so I did the following
> operations:
>
> Apache DS--->Open Configuration File...
>
> While,an error occurred with the following error message in the popup
> dialog:
>
> An error occurred when reading the file.
> Connection time out:connect Nested exception:Connection time out:connect
>
> I tried this operation many times,no matter at home or my office,the
> result
> is the same.
> I want to check if there is a log file in the Studio tool,but I found
> none.
>
> I think the "Apache DS--->Open Configuration File..." will give me a view
> of
> structural frame of the configuration file,but now I can not use it.
> Can anybody help me?
> Thanks a lot!
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message