directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben Madsen - Mailing List <bmad...@ecbridges.com>
Subject Re: [Spam] Re: Creating custom schema in ApacheDS-1.0.2
Date Thu, 04 Oct 2007 20:22:17 GMT
In the project's POM.XML file, the parameter is set at:

<project>
  <build>
    <plugins>
      <plugin>
        <artifactId>maven-compiler-plugin</artifactId>
        <configuration>
          <source>1.5</source>
          <target>1.5</target>
        </configuration>
      </plugin>
    </plugins>
  </build>
</project>

Hope this helps.
-Ben

Sura, Bhupesh wrote:
> I am new to maven. I have looked everywhere to set the javac version to 1.5. I understood
that for 'maven-compiler-plugin' I need to set the source and target versions to 1.5 but don't
know where to set it.
>
> I am very sorry for posting such simple questions. If I cannot get the compile working,
I am planning to compile the classes and make a jar from my IDE.
>
> Thanks for your patience,
> Bhupesh. 
>
> -----Original Message-----
> From: Emmanuel Lecharny [mailto:elecharny@gmail.com] 
> Sent: Thursday, October 04, 2007 2:50 PM
> To: users@directory.apache.org
> Subject: Re: [Spam] Re: Creating custom schema in ApacheDS-1.0.2
> Importance: Low
>
> oh...
>
> have you checked the java version used by Maven ?
>
> On 10/4/07, Sura, Bhupesh <Bhupesh.Sura@us.widerthan.com> wrote:
>   
>> Maven 2.0.7
>>
>>
>> apacheds-schema-archetype.sh still fails.
>>
>> In the meanwhile, I manually created the folder structure for foo-schema as given
in the wiki and did a mvn clean and mvn package.
>>
>> It generated the sources for me but the compile failed with the following error.
>>
>> generics are not supported in -source 1.3 (try -source 1.5 to enable 
>> generics)
>>         ArrayList<String> list = new ArrayList<String>();
>>
>>
>> How do I set the java version for compile. I have jdk 1.5 already installed on my
machine with the path set.
>>
>> Thanks
>> Bhupesh
>>
>> -----Original Message-----
>> From: Emmanuel Lecharny [mailto:elecharny@gmail.com]
>> Sent: Thursday, October 04, 2007 2:25 PM
>> To: users@directory.apache.org
>> Subject: [Spam] Re: Creating custom schema in ApacheDS-1.0.2
>> Importance: Low
>>
>> Hi,
>>
>> which maven version are you using ?
>>
>> On 10/4/07, Sura, Bhupesh <Bhupesh.Sura@us.widerthan.com> wrote:
>>     
>>> I am trying to create a custom schema in ApacheDS-1.0.2. I am 
>>> following the wiki page 
>>> http://cwiki.apache.org/confluence/display/DIRxSRVx10/Custom+Schema
>>> <http://cwiki.apache.org/confluence/display/DIRxSRVx10/Custom+Schema> .
>>>
>>> I was able to get the sources and do a maven install.
>>>
>>> when I run the command
>>>     apacheds-schema-archetype.sh com.acme foo-schema it fails as
>>> following.   ( Note that I am running this on windows platform)
>>>
>>>
>>>
>>>
>>> C:\Program Files\apacheds-1.0.2\src\schema-archetype>mvn
>>> archetype:create -DarchetypeGroupId=org.apache.directory.server
>>> -DarchetypeArtifactId=apacheds-schema-archetype -Darchetyp
>>> eVersion=1.0.2 -DgroupId=com.acme -DartifactId=foo-schema [INFO] 
>>> Scanning for projects...
>>> [INFO] Searching repository for plugin with prefix: 'archetype'.
>>> [WARNING] POM for
>>> 'org.apache.maven.plugins:maven-archetype-plugin:pom:1.0-SNAPSHOT' 
>>> is invalid. It will be ignored for artifact resolution. Reason: 
>>> Failed to validate POM for pro ject 
>>> org.apache.maven.plugins:maven-archetype-plugin at Artifact 
>>> [org.apache.maven.plugins:maven-archetype-plugin:pom:1.0-SNAPSHOT]
>>> [INFO]
>>> --------------------------------------------------------------------
>>> --
>>> --
>>> [ERROR] BUILD ERROR
>>> [INFO]
>>> --------------------------------------------------------------------
>>> --
>>> -- [INFO] Error building POM (may not be this project's POM).
>>>
>>>
>>> Project ID: org.apache.maven.plugins:maven-archetype-plugin
>>> POM Location: Artifact
>>> [org.apache.maven.plugins:maven-archetype-plugin:pom:1.0-SNAPSHOT]
>>> Validation Messages:
>>>
>>>     [0]  'dependencies.dependency.version' is missing for 
>>> org.apache.maven.archetype:maven-archetype-creator
>>>
>>>
>>> Reason: Failed to validate POM for project 
>>> org.apache.maven.plugins:maven-archetype-plugin at Artifact 
>>> [org.apache.maven.plugins:maven-archetype-plugin:pom:1.0-SNAPSHOT]
>>>
>>>
>>> [INFO]
>>> --------------------------------------------------------------------
>>> --
>>> -- [INFO] For more information, run Maven with the -e switch [INFO]
>>> --------------------------------------------------------------------
>>> --
>>> --
>>> [INFO] Total time: < 1 second
>>> [INFO] Finished at: Thu Oct 04 12:36:59 EDT 2007 [INFO] Final Memory:
>>> 1M/2M [INFO]
>>> --------------------------------------------------------------------
>>> --
>>> --
>>>
>>>
>>> I may be missing something or doing somethig worng. I am new to maven.
>>> Any help is greatly appreciated.
>>>
>>> Bhupesh.
>>>
>>>       
>> --
>> Regards,
>> Cordialement,
>> Emmanuel Lécharny
>> www.iktek.com
>>
>>     
>
>
> --
> Regards,
> Cordialement,
> Emmanuel Lécharny
> www.iktek.com
>   

Mime
View raw message