directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Zoerner <ste...@labeo.de>
Subject Re: ApacheDS version 1.0.2 or 1.5.1 to use?
Date Wed, 03 Oct 2007 21:05:07 GMT
Sura, Bhupesh wrote:
> We are planning to use apacheDS for our project unix platform. As I
> understood from the wiki is 1.0.2 is the stable release and 1.5.0 and
> 1.5.1 are development / beta releases and the next stable release would
> be 2.0. Is that correct?
> The features I am currectly looking for are
>     Simple authentication
>     Custom schema ( custom objectClasses and attributes )
>     Custom partition
> I am assuming that the ApacheDS 1.0.2 provides the functionality.

Basically Yes.

For simple authentication, it doesn't make any difference.

The support for custom schema elements in the 1.5 branch is much better 
than in 1.0, dynamic schema modifications for instance are not possible 
in 1.0.

What do you exactly mean by "Custom partition"? You can define your own 
partitions (suffixes) for entry storage in both versions. Or do you plan 
to write your own partition implementation (backend)? Which is also 
possible in both versions, but not an easy task.

> Lastly will the ldap browser Apache Directory Studio 1.0.1 work with
> ApacheDS 1.0.2?

Yes. It should work with any LDAPv3 compliant directory server, by the way.

Thanks for considering our software. Feel free to ask, if you need any help.

Greetings,
    Stefan


Mime
View raw message